Always untrusted domain

My server recently crashed and I’m trying to rebuild the services. I am using Ubuntu 22.04 fresh install and trying to install ownCloud with docker compose from the documentation page.

No matter what I do in my .env, I get the untrusted domain for the splash page (whether server:8080,, or 192.168.x.x:8080):

You are accessing the server through an untrusted domain.

Please contact your administrator. If you are an administrator of this instance, configure the “trusted_domains” setting in config/config.php. An example configuration is provided in config/config.sample.php or at the documentation.

My env looks like this (names changed to protect the ignorant):


If I use lynx I can get to a login page and login as admin, but can’t change anything as it all seems to rely on Javascript or I get bad html notifications from lynx.

Can anyone please provide some guidance? Thanks in advance!

For anyone else suffering the same issue, rolling back to


solved the issue. There must be something wrong in 10.13.x as I didn’t change anything else in the config and now everything works fine.


i’m not sure what is used in the UCS appliance but if this is also using the Docker container then i think this thread could be a duplicate of:

Might be. Sounds like s/he was able to access via IP. I wasn’t able to access via IP or hostname. I also tried changing the config.php to no avail. My understanding is config.php isn’t used anymore (I don’t really know). I just know rolling back to 10.12.2 solved my issue.

Of course now my ownCloud link in Windows reads ownCloud - username@IP_ADDR, which I really don’t like, but it’s better than not having my files…


if it is Docker specific (i’m running ownCloud 10.3.2 without Docker without this problem) then i think it could be possible to open an issue for the ownCloud people over here:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.