Can not connect by client or app to my server


I reinstalled my server, and so I installed a new owncloud server to my fresh installation.

Since Owncloud 8, it is not that easy, to host a own server, than in the past. A lot of thinks are reallay hard, when you are not a expert to this all.

So I was happy to find solutions for all errors on warnigs, during the installation and after it (e.g. /dev/urandom andstrict headers)

Now I want to sync my files, with the desktop client for windows, as the last few years, but I cant connect.
A error tells me, I have no acces to the server.

I installed the client on my laptop and I have there the same problem.

I can connect vie Browser, no problem. I can also upload files and everything seems working.

My last test was to bought the mobile app for my android smartphone.

I can also not connect there. I get the error that my username or password is incorrect.

I try again in browser. No problem. I changed my password, created a dummy user, but I can still not login from outside of my browser.

I can also not make a integrity check, because it tells me "Integrity checker has been disabled. Integrity cannot be verified."

So I found out, I needed to disable nginx for this domain. and I wa sable to login.
But it was only my dummy user. So i logged out,
and now the client dont find my server ( Can not download my https://mydomain.tld/status.php).

When I open it in my browser, it looks so: {"installed":true,"maintenance":false,"version":"","versionstring":"9.1.3","edition":""}

I added it to my config, still not working. Please help me with that issue !!!
Thank you

I run the server on PHP 7.0.15

My config:
$CONFIG = array (
'instanceid' => '[My id]',
'passwordsalt' => '[my salt]',
'secret' => '[my secret]',
'trusted_domains' =>
array (
0 => '[my domain]',
'datadirectory' => '/var/www/vhosts/[my domain]/data',
'overwrite.cli.url' => 'https://[my domain]',
'dbtype' => 'mysql',
'version' => '',
'dbname' => '[my DB name]',
'dbhost' => 'localhost',
'dbtableprefix' => 'oc_',
'dbuser' => '[MY DB]',
'dbpassword' => '[MY PW]',
'logtimezone' => 'UTC',
'installed' => true,
'mail_smtpmode' => 'php',
'mail_smtpsecure' => 'ssl',
'mail_from_address' => 'owncloud',
'mail_domain' => '[my domain]',
'mail_smtpauth' => 1,
'mail_smtpauthtype' => '',
'mail_smtphost' => '',
'mail_smtpport' => '',
'mail_smtpname' => '',
'mail_smtppassword' => '',
'appstore.experimental.enabled' => true,
'integrity.check.disabled' => false,

@bokulistikz Please move this thread into the following category

This is not an issue in ownCloud itself but within your webservers configuration or your network so the category there fits your problem.

Okay I moved it to this category.

When I take a look to my apache errorlog, I found this:
Error 401 PROPFIND /remote.php/webdav/ HTTP/1.1

401 means "Unauthorized" so this is most likely a webserver configuration issue. A large FAQ containing all known background info how to fix your environment is available here:

Here is my solution, disable ngin-x and add following part to HTTP.conf:

RewriteEngine on
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

I hope it will help...