Cannot Login After Upgrade to 10.0.0.9


#1

Hey Guys -

I’m stuck in a failed upgrade from 10.0.8.x to 10.0.0.9. Below are the details…

After putting it off for a few days, I acknowledged the message in my ownCloud web interface that I needed to update to 10.0.0.9. As my instance exists in the cloud, I do not have CLI access to it - just cPanel & myPHPAdmin - so I opted to use the Updater within Settings.

Below is how I upgraded:

  • Logged into web interface
  • Went to Admin and choose to update which appeared to work correctly
  • Post update, I was redirected back to my ownCloud login page (https://mydomain.com/owncloud), but the site was in maintenance mode
  • I let it sit for about an hour thinking it still may be doing things, but after no changes and the dates on any files changing, I disabled Maintenance Mode by editing config.php then refreshing the webpage but this resulted in a page with a start button and the text:

App update required
Please make sure that the database, the config folder and the data folder have been backed up before proceeding.
To avoid timeouts with larger installations, you can instead run the following command from your installation directory:
./occ upgrade

Clicking Start, I almost immediately get a page with the following message:

Updating to 10.0.9
OC\RepairException: Upgrade is not possible

Repair warning: You have incompatible or missing apps enabled that could not be found or updated via the marketplace.
Repair warning: Please install or update the following apps manually or disable them with: occ app:disable calendar occ app:disable contacts occ app:disable files_pdfviewer occ app:disable files_texteditor occ app:disable tasks occ app:disable templateeditor
Repair warning: For manually updating, see https://doc.owncloud.org/server/10.0/go.php?to=admin-marketplace-apps
Detailed logs
The update was unsuccessful. Please report this issue to the ownCloud community.

As I don’t have CLI access, I cannot run those commands; so tried a different method. Using myPHPAdmin, I executed the below queries which a post said disables the apps:

update oc_appconfig set configvalue=“no” WHERE appid=“calendar” AND configkey=“enabled”;
update oc_appconfig set configvalue=“no” WHERE appid=“contacts” AND configkey=“enabled”;
update oc_appconfig set configvalue=“no” WHERE appid=“files_pdfviewer” AND configkey=“enabled”;
update oc_appconfig set configvalue=“no” WHERE appid=“files_texteditor” AND configkey=“enabled”;
update oc_appconfig set configvalue=“no” WHERE appid=“tasks” AND configkey=“enabled”;
update oc_appconfig set configvalue=“no” WHERE appid=“templateeditor” AND configkey=“enabled”;

Once done, I tried clicking “Start” again, but got the exact same error message with the same apps listed. I looked in my apps folder, but none of the apps listed have a folder in it. I also downloaded the manual 10.0.0.9 installer to see if it had the app folders for the mentioned apps, but it didn’t either so I’m stuck.

Below are a few other details generally requested for a post plus logs which I was able to get. Any suggestions for a resolution and perhaps an overview of steps to take would be very much appreciated.

Thank You!


Behaviour

Expected: ownCloud displays login screen and works :slight_smile:
Actual: I get the Start button & error when executing upgrade

Server configuration

Operating system: n/a / cloud
Web server: owncube.com
Database: mysql
PHP version: 7.0.31
Install Folder: domain.com/owncloud
SSL: Yes - 3rd party signed cert
Results from “…/index.php/settings/integrity/failed”: Resulting page displayed the same Update button page that appears when attempting to log in
The content of config/config.php:
Click here to view (edited for security)
Generate Config Report: I cannot access via web and do not have CLI
List of activated apps: Unknown - Below are list of folders currently in my “apps” folder, though:

  • comments
  • configreport
  • dav
  • encryption
  • external
  • federatedfilesharing
  • federation
  • files
  • files_external
  • files_sharing
  • files_trashcan
  • files_versions
  • files_videoplayer
  • firstrunwizard
  • market
  • notifications
  • provisioning_api
  • systemtags
  • updatenotification
  • user_external
    Are you using external storage, if yes which one: I used SFTP for a while, but disabled / deleted it prior to upgrading as wasn’t stable
    Are you using encryption: No - just 3rd party SSL cert
    Are you using an external user-backend, if yes which one: No / none

Client configuration

Browser: Google Chrome Enterprise
Operating system: Windows 10 x64 1803
Client Version: 2.4.3 build 10188 - Having no issues with client when server is working, though

Logs

update.log
Notes

  • Click here to view (edited for security)
  • It’s timestamp is from when I performed the initial update at 10:17am. Subsequent updates from clicking the Update button evidently do not appear in it_
  • It states “ownCloud 9.0.11.2 found” at the beginning of the log, however I’m 100% sure I was running 10.x prior to initializing the update

owncloud.log
Notes

  • Click here to view (edited for security)
  • At the end the log states it’s upgrading from 10.0.9.5 to 10.0.9.5. Although it may be the case at the time it was logged, my initial upgrade this morning from from 10.0.8.x.
  • I replaced instances of my WAN / public IP with “1.2.3.4”. I found “46.166.151.51” is one of owncube’s IPs

Thanks again!


#2

Did you use the search feature on this forum before posting this?

if you just type 10.0.8 and 10.0.9 the following comes up:


#3

Thanks for the reply. I had searched, but looked again more in depth and eventually found something about editing tables in the DB.

I opened myphpadmin, went to the table “oc_appconfig”, then changed the value of “configkey” “enabled” from “yes” to “no” for each app listed in the error (about 7 of them). Once done, I refreshed my homepage and clicked the Start button. This went further, but resulted in the message:

Repair warning: The file cache contains entries with invalid path values for the following storage numeric ids: 6
Repair warning: Please run occ files:scan --all --repair to repairall affected storages or run occ files:scan userid --repair for each user with affected storages Repair warning: The file cache contains entries where the parent id does not point to any existing entry for the following storage numeric ids: 2 2 2 2 2 2 2 2 2 2 6 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 7 Repair warning: Please runocc files:scan --all --repair` to repair all affected storages
Starting code integrity check

After more research, I refreshed then was able to log in. In the Admin console, I see that integrity check failed. When looking at the list of affected files, I get:

Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results

  • core
    • EXTRA_FILE
      • error_log

Raw output

Array
(
[core] => Array
(
[EXTRA_FILE] => Array
(
[error_log] => Array
(
[expected] =>
[current] => 546de0bebbcf3b492bde2c94e0c3d91faff9fe0a3427adf4ff64243375ba72cb00f0b2c57b66d19ef6f6c24b24c8d49dc7ffc49594378f8c5be11109fc057312
)

            )

    )

)

The problem is that there isn’t an “error_log” file within core or any of it’s folders. Is that the issue, perhaps? I looked in an extracted copy of the 10.0.0.9 download and it didn’t exist either nor do I get search results for the file in these forums.

Suggestions? Thanks!

UPDATE
Scratch that: I searched the entire /owncloud folder and its children for “error*” and received many results. Evidentally, I’m blind because there was an “error_log” file in the root of /owncloud - I was looking for it in /owncloud/core initially. I deleted it (after backup) then rescanned and think I am good to go.

Thanks!


#5

Did the solution of @bzowk worked for you?