Cannot login with browser to owncloud server any more


#1

I had installed owncloud at my hoster and it has worked fine for quite a while. I have installed several users for own use.
I use mainly Goodsync for synchronisation jobs.
Since yesterday(?) I cannot login via browser from my Windows PC to the server address www.mydomain.xyz/owncloud.
Error message after entering password: This connection is not safe etc (actually in another language).
Goodsync can access the data for different users without problem with the same login and password though.
Yesterday I had logged into the SQL-database searching for locked files but without changing anything, maybe at the same time a sync job was running. Could that have damaged the database an the login procedure data?
How can I reset the login procedure? Any other idea how to get admin access again?


#2

If you're getting a "this connection is not safe" then its something unrelated to ownCloud and most likely somehow related to a broken SSL/TLS setup. You might need to use tools like https://www.ssllabs.com/ssltest/index.html to check and fix your setup.


#3

Thanks for the input.
I never had an https connection with this my own installation, only http. After entering the password the message appears and the password entry field is empty again, but no notice, that the password is wrong. Also the Goodsync client uses http-connections without problems.
Any more idea?


#4

Your best bet is probably do an research on your favorite search engine about the "this connection is not safe" message and where this is coming from. This should give you additional pointers to look for this issue.


#5

Other browsers than Firefox do not necessarily give the connection notice. E.G. Opera just returns a blank password entry field without any further notice after entering the correct password. Hard to believe that from one moment to the other the same connection is refused which has been working with http protocol for quite some time.
Is it possible to reset the password for the admin from within the config files on the server?


#6

Its also hard to believe that something like this is happening without any changes on server side. So this is something additionally you need to research (logfiles of webserver, php, data/owncloud.log and the browser console might help here).

Yes, this is possible but i guess won't solve your issue if it is found somewhere on server-side:

https://doc.owncloud.org/server/latest/admin_manual/configuration_user/reset_admin_password.html


#7

Login with Goodsync is operational. So you do not have a problem with the login itself. It would not solve your issue to reset passwords etc.
"Connection is not save" points to a certificate problem. You connect to http://yourserver? When Firefox gives you the error, are you redirected to http**s**://yourserver? Maybe it is helpful to cite the whole message in the original language (I thing German?) or a screenshot.
And take a look in the logfiles (/var/log/apache2/ssl_access.log, /var/log/apache2/access.log, /var/log/apache2/error.log (for Apache, other web servers have similar logfiles) and in the ownCloud log files).


#8

I had a similar problem recently, after turning on CloudFlare for my wordpress website. CF does some optimization to the code that is not compatible with OC login web page.
I can't remember exactly what I did, but basically I turned off all CF optimization switches one by one, until I found the problematic one. That did the trick for me.


Th login does not work