Can't upload any file

I just installed the latest version 10.0.4 and I can't upload any file (documents and photos). I use php 7.0 / MySQL, the log file does not record any error when trying to load a file (either with drag & drop or with the + menu from the folders) I can create new folders from the interface, the CHMOD are compliant, no particular restriction on the file transfer size (> 512 MB).
When I drop a file, the loading progress bar runs up to 100%, at the end no loaded file appears and the folder .../data/user/files/documents (or photos) is empty. No thumbnail created either.

Any idea?

just spit-balling.. but have you confirmed that the data directory is in its original location and that there is space on the partition, and if you moved it, did you update database and other areas of the data directory's new location?

Hope that helps :slight_smile:

I didn't move anything, I am able to restore the files from the trash and delete them again. Every new upload does not do anything.

I deleted the installation and the database and started from scratch: new database and new installation with the web installer. The results are the same and still no error in the log file but this (I replaced the IP by IP the root directory by ROOT). I don't think that this message has something to do with the upload.

{"reqId":"WkKltbley6CuRBT7TcpbOQAAANU","level":3,"time":"2017-12-26T19:40:37+00:00","remoteAddr":"IP","user":"Herve","app":"PHP","method":"GET","url":"\/index.php\/settings\/admin?sectionid=general","message":"opendir(\/home\/ROOT\/public_html\/cld\/themes): failed to open dir: No such file or directory at \/home\/ROOT\/public_html\/cld\/apps\/templateeditor\/lib\/mailtemplate.php#155"}

A quick update: I did not make any change since yesterday but I managed to upload and to share some files with my tablet (Android + Firefox 57.0.1) but this is still impossible with my laptop (W7 / Firefox 57.0.2 / Chrome 63.0.3239.108). There is still no relevant fault log about this!

That is weird... I am not expert, and can only apply logic to your issue. I noted that the error message that you posted is common with issues adding custom email themes, missing a directory.

Found the the fix for that here:

That does not appear to be a part of your issue. So at this point I would double check that there is nothing conflicting with ownCloud (like firewall rules or other webpages in apache)

I hope someone with more experience chimes in soon.

The description about the progress bar looks similar / the same as in which might be caused by a limitation / some restrictions in the PHP / webserver configuration.

Thank you Charles and Tom for your inputs.
Well the behavior is similar of what Tom pointed to me! In fact with both tablet and laptop the upload of file above 1M does not happen!!! I never had this issue with the previous version of Oc.

My config is the following:

Php 7:
upload_max_filesize 1G
post_max_size 1G
memory_limit 1G
max_input_time 3600
max_execution_time 3600


htaccess mod_php7.c
php_value upload_max_filesize 513M
php_value post_max_size 513M
php_value memory_limit 512M
php_value mbstring.func_overload 0
php_value default_charset 'UTF-8'
php_value output_buffering 0
SetEnv htaccessWorking true

I've read again and again the adjustments which have to be done, I think my config should be good enough to upload the files of size above 1M ...

I changed my photo of profile with a picture of 8M and the upload works fine, that's weird.

I just used the windows app for Oc, I sent and synchronized 3 photos, each photo of 2MB file size without issue.
Came back to the administration web page, I deleted them and tried to upload the same photos, no success!!!

That's make no sense to me....

I think the apps / sync clients are not affected by any upload limits in your webserver as those are using some sort of chunking which is splitting the uploaded files into some smaller parts.

Only the web client limits the upload to 1 MB for any file to share but not the photo of the profil, the app has no limits. A bug?

Hi! I recently updated from 9.x to 10.x (I delayed the migration since I had many issues when migrating from 8.x to 9.x) and I have the same issue: I can’t upload anything.

I don’t want to use the sync client because I have a bad experience with it. So being unable to upload from web client is very … frustrating.

Did you solve the issue?

No logs -> no bug -> your setup problem.

Consider to open a new ticket with all the relevant information, including, but not limited to, how did you update the server (manually, via package, updater app…) and specific versions. (Use the template)

“I can’t upload anything” can be caused by several things, from a wrong installation / update to problems with permissions in the server. With the litle information you’ve given isn’t possible to determine the cause.

1 Like

OK. I`ve created a new question describing my problem. I am using default setup, so if no logs is no bug and my setup problem. your setup wizard has a setup problem.