CardDav not syncing with SSL Proxy in use


#1

On Owncloud 9.1.0 Installation Contacts dont sync for me with i phone. I nailed down the problem to the ssl proxy which is sslsites.de offered by my webhoster. When i turned off ssl proxy all worked fine.
it seems the user name and password isn´t submitted correctly

Exception: {"Message":"HTTP\/1.1 401 No 'Authorization: Basic' header found. Either the client didn't send one, or the server is mis-configured, No 'Authorization: Basic' header found. Either the client didn't send one, or the server is mis-configured","Exception":"Sabre\DAV\Exception\NotAuthenticated","Code":0,"Trace":"#0 [internal function]: Sabre\DAV\Auth\Plugin->beforeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#1 \/kunden\/\/cloud\/3rdparty\/sabre\/event\/lib\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#2 \/kunden\/cloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(446): Sabre\Event\EventEmitter->emit('beforeMethod', Array)\n#3 \/kunden\/cloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(248): Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#4 \/kunden\//cloud\/apps\/dav\/lib\/Server.php(169): Sabre\DAV\Server->exec()\n#5 \/kunden\/\/cloud\/apps\/dav\/appinfo\/v2\/remote.php(29): OCA\DAV\Server->exec()\n#6 \/kunden\/cloud\/remote.php(164): require_once('\/kunden\/114828_...')\n#7 {main}","File":"\/kunden\/\/cloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Auth\/Plugin.php","Line":188,"User":false}

could anyone give me please a hint how to configure this right?


#2

If you control the ssl-proxy, you can fix the settings:

Do you have any option to modify for the ssl-redirect?


#3

think i cant modify the proxy itself as it is the standard of my shared hosting


#4

You could also have a look at proxy specific settings of oC like described here:

https://doc.owncloud.org/server/9.1/admin_manual/configuration_server/reverse_proxy_configuration.html#multiple-domains-reverse-ssl-proxy


#5

from this lines

"trusted_proxies" => ['10.0.0.1'],
"overwritehost" => "ssl-proxy.tld",
"overwriteprotocol" => "https",
"overwritewebroot" => "/domain.tld/owncloud",
"overwritecondaddr" => "^10.0.0.1$",

only trusted proxy and last one i didnt have in my config.
i need to speak with my hoster for the ip of sslsites and verify later if this helped


#6

inserting the ip didnt change the problem
changed from ssl proxy to a real ssl certificate but still no sync of contacts
i also tested to connect to cloud with windows explorer connecting trough webdav but then a windows opens asking for username and password - but it doesnt accept the userdetails

How can i test at what point the userdetails get lost?


#7

Hi,

there is a larger FAQ describing all known information about such WebDAV issues which might happen within your environment:


#8

Good Morning
A big thank you Real Rancor for the time you spend to try to offer an answer.
I myself spend a couple of hours to try all of them just finding out the majority of proposals to change code are outdated because they relate to old versions of owncloud.
Don´t take this as an offend your help is very much appreciated.
At this point i can say the solution to my problem was the very last i wanted to try:
I deleted Owncloud and also the Database. Upload the recent version and made a fresh start---> e´voila now it works.