Changing Background and fonts at Owncloud 10.0.9


#1

Hey Guys!

Im new here so sorry for the noob question.
I downloaded the vmware installer(ESXi) of the latest owncloud,I installed it connected to my AD set up to be owncloud the default site at start, but now to change to themes i stuck.

Im on lvl 0 az linux i only know basic things.
I connected on the console or winscp but i didnt find where are owncloud installed.
Thanks for the help.

bolvar


#2

You can follow this documentation for creating a new theme app: https://doc.owncloud.org/server/10.0/developer_manual/core/theming.html


#3

Dear Karakayasemi!

Yeah i found this, but in my post the main problem that i cant find the installed folder of owncloud.
Under var/www there are nothing. I connected via winscp and vmware console two the same problem.
Im not pro at linux, maybe but the account i login has root privilages.


#4

Hmm, sorry for my misleading. I did not use vmware installer and do not know the default Document Root for this appliance. As far as I see, it is using Apache. If you have ssh access you can run apachectl -S command and see Document Root of the Apache configuration. I hope it helps.


#5

I think this helps:

https://doc.owncloud.com/server/10.0/admin_manual/appliance/login_information.html


#6

Thanks dimitry!
Somehow i skipped this page, and if I understand correctly i cant login from winspc to the container?.Only from putty or the esx console?.

bolvar


#7

only from putty. You connect to the host, and then execute the command that get’s you to the container.


#8

Im a little bit sad, but can you help mi in this case how cani change the logos/background?

bolvar


#9

you can look at our docs, search for theming.


#10

Yes i tried, but with this type of owcloud install there are nothing.

Im not a linux pro maybe i miss something but if i cant connect to the owncloud directory with winscp how do i upload any picture for it.


#11

I think @cscherm is the right guy here. He is a theming virtuoso.


#12

Using this would be my first guess. Once you have the picture in your ownCloud you can copy it in to a theme.

image


#13

Cute but there are no upload button in my dashboard :confused:


#14

Then there is something seriously wrong with your server / you don’t have permissions to write in your data directory / you are using some adblocker.


#15

I dont think so, and i have permission to it.
I can show you on teamviewer what is the problem if you think, at winscp i cannot se the files, in the console when i type in the command that you give, (univention-app shell owncloud) i see the files in the docker.

The main problem that the theming descriptions are not for the docker install i think, or im missunderstood something.


#16

what account are you using to log in?


#17

I tried the administrator what i gived in the install, my own what i made for myself, and the owncloud default is denied.

Both accounts are have root privilages if i give a sudo -s.


#18

we are now at 17 messages, I suggest you delete this vm and start from scratch without the AD integration.


#19

The problem is i need the ad integration for the logins.

If i saw correctly sso are only supported at the enterprise version.


#20

No you don’t.

You can setup the appliance in it’s own domain and then after the setup you just ad the AD server afterwards in the user authentication settings. Then your AD users can log in with their AD credentials in ownCloud.