Command Line Upgrade

hosting

#1

Bom dia, tudo bem?

O meu Owncloud está hospedado em um servidor Centos, e ao efetuar a atualização deu muitos erros, mas consegui estabilizar a situação, porém agora fica uma mensagem dizendo image

Não sei o que fazer, pois estou a dias tentando atualizar e não consigo.


#2

Unfortunately my Portuguese is not that great. ;).

In the post below, you’ll find exactly the same problem:


#3

Thanks for listening alfredb!

I’ll follow this process.

I am having difficulty setting up the command in centos, since the command quoted in the document does not work.


#4

Isn’t it because the webserver is running by another user than www-data?


#5

I already changed to apache


#6

Hey,

generally i think this is the worst description of an issue some one can give. :confused:

Please try to provide more info like e.g. the steps you did while trying to run the command line upgrade, the issues you have faced with that and any possible errors you got.


#7

Sorry, I’ll try to be more detailed.

Access the VPS which is a Centos 6.10, root access, I enter the sudo apache / opt / rh / php56 / root / usr / bin / php / var / www / html / owncloud / occ upgrade -h code, but the command back invalid, I already tried to mount several types of command, but all to no avail.

ea-php-cli Copyright 2017 cPanel, Inc.
Status: 404 Not Found
Content-type: text/html; charset=UTF-8

Thank you very much in advance.


#8

Nobody understands this, I don’t either.

cd /var/www/html/owncloud
sudo -u apache php occ upgrade

Hoping your php can be found in the path.


#9

You are now returning the following error.

[root@vps owncloud]# sudo -u nobody php occ upgrade
Status: 404 Not Found
Content-type: text/html; charset=UTF-8


#10

Hey,

maybe the php binary is called differently on CentOS? I think it could worth to ask at a CentOS support forums how PHP can be used on such environments from command line.


#11

Why nobody? I thought CentOS uses apache as user for the webserver…

Master your system!


#12

Once again I am grateful for the attention, so I contacted the hosting support and informed that the user is nobody.

Thank you very much in advance.


#13

Hey, if you’re already in contact with your hosting support maybe you can ask them the previous question:


#14

That was it.
Thank you all involved.
If you want you can close this topic.


#15

You have to close it, by marking it as solved.


#16

Ok, thank!
living and learning


#17

Hey,

it would be great if you could share some details on your solution. This helps other users reading this thread to find a similar solution when running ownCloud on CentOS and without having the knowledge how to run such commands on their environments.