Could not detected compatible server

ownCloud 979bb9
Libraries Qt 6.4.3, OpenSSL 3.1.2 1 Aug 2023
Using virtual files plugin: wincfapi
OS: windows-10.0.22621
QPA: windows

Server is in Virtualbox and im not sure how to check information about it.
I can only log in thanks to the server URL, other methods do not work (highlighted in gray).
Every time you try to log in to the address (example)
http:// I get the error “Could not detect compatible server at “http://”. Before this, a message also pops up that the connection is not secure and asks me to confirm the login.
I tried to search on the forums, but I just started working with owncloud and in didn’t help. I don’t quite understand how to solve the error.
However, when I try to enter “https://” I get the error “TLC Certificate Error”:
The host name did not match any of the valid hosts for this certificate

with Certificate ucs-4895.example.intranet

Organization: Example
Unit: Univention Corporate Server
Country: GB

Fingerprint (MD5): 0cdbd782f9c2273fd9eb484d74dfb028
Fingerprint (SHA1): db3c57da6ad7c4dc58f6016b9a1533c16157cb67
Fingerprint (SHA256): 6361b7af58fc1e8f8491d6376fcf9b378aa9b21a313b7fdb38527cb49dd7846d

Effective Date: Tue Jan 23 05:07:07 2024 GMTExpiration Date: Sun Jan 21 05:07:07 2029 GMT

Issuer: Univention Corporate Server Root CA (ID=sKA1ye1q)

Organization: Example
Unit: Univention Corporate Server
Country: GB

The root certificate of the certificate chain is self-signed, and untrusted

with Certificate Univention Corporate Server Root CA (ID=sKA1ye1q)

Organization: Example
Unit: Univention Corporate Server
Country: GB

Fingerprint (MD5): 3141422c78bd4d50b8e087386af9a511
Fingerprint (SHA1): 5516f2b5dd2981d86af22dc0d4dec3c2805512d6
Fingerprint (SHA256): 06c66e77d7731aac9a20d8cbfbcbefb913640c8912e5b183c9570a01acbb3ed5

Effective Date: Tue Jan 23 05:06:44 2024 GMTExpiration Date: Sun Jan 21 05:06:44 2029 GMT

Issuer: Univention Corporate Server Root CA (ID=sKA1ye1q)

Organization: Example
Unit: Univention Corporate Server
Country: GB

Most likely I need to configure certificates, but can someone explain how to do this?
If this is not the problem, then what should be done?

You will be better off asking for support on that appliance directly from the Univention community.

You are also going to need to use a domain name of you wish to obtain and use a valid certificate.



while the UCS seems to be not provided by the ownCloud people it seems they are providing some basic documentation about Certificate management in their documentation:

which also links to the Univention forums providing more guidance:

1 Like

I got the same prob.
Have anyone found a resolution on this?

I tried how to add certificates from tom42 but i get errors.

this is the problem.

It is not clear that you have the same problem that @WhyAmIHere encountered. While your inquiry would be better off in its own topic, you are far more likely to engage with people who have experience with Univention Appliance on their forums which are linked in my previous reply.

When sharing console output, please avoid screenshots as they are difficult to read on mobile devices and they are impossible to copy and paste from. It’s more beneficial to copy the console text and paste it as </> Preformatted text.

As for your command not found, it is likely that that you didn’t try that command with sudo. It is probably under sbin which isn’t in your user’s path.

1 Like

I am really sorry for the feedback but i cant copy from this VM.

Btw. you were right. I tried to execute with sudo and the command executed succefully this time:

sudo -i
ucr set apache2/ssl/certificate=“/etc/myssl/cert.pem”
ucr set apache2/ssl/key=“/etc/myssl/private.key”

Then i tried to execute this command

sudo service apache2 restart

And i got the error:

Job for apache2.service failed. See “systemctl status apache2.service” and “journalctl -xe” for details.

And i am loosing the connection with the server. But if I execute the commands:

ucr unset apache2/ssl/certificate
ucr unset apache2/ssl/key
sudo service apache2 restart

everything turns back to normal

this is the server screen

I created a new thread with the same name.

1 Like

Try to add /owncloud after address like: “https://”

Please mark this as a solution.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.