CSRF check failed after upgrade to 9.1

known_bug
9.1.x
help

#1

Steps to reproduce
1. did an upgrade from latest 9.0.x version to 9.1 via apt-get update && apt-get upgrade -> no errors
2. run occ upgrade -> no errors
3. disabled maintenance mode

Actual behaviour
when trying to login via web-page it shows: Access forbidden (Zugriff verboten) CSRF check failed.
windows clients also can not connect to owncloud server

Server configuration
server based on vmware image provided from owncloud and regularly updated/upgraded to latest version.
Operating system: ubuntu


Access denied CSRF check failed
After upgrade to 9.1 - login problems, CSRF, admin problems,
#2

Maybe related to:


#3

thanks, disabling files_sharing via occ worked. I can login to owncloud.

But, I am using this feature quite often to share links. How can I get this functionality back?


#4

The issue has been reported at the bugtracker as you can see above. You can subscribe to that issue to get informed if a solution is provided there.


#5

thanks for the quick support!


#6

I had the same problem. Clients were not able to log in but I was allowed to log in as adminstrator and I disabled the file sharing app from the admin panel. Now my clients can log in but can't share the files of course. I hope you fix this soon because file sharing is one of the key reasons we use OC...


#7

Please also post your details in the ticket, the more clues the better :slight_smile:


#8

I have the same problem.

After yum update, it updated to latest version on CentOS 7. The database update went fine, but now I am unable to log in anymore, neither as a user or administrator.

How can I help to supply more information?

How can I disable the files_sharing?
I used sudo -u apache php occ app:disable files_sharing but it did not help.

Kind regards

EDIT:
List of enabled/disabled apps:

Enabled:
- activity: 2.3.2
- comments: 0.3.0
- dav: 0.2.5
- federatedfilesharing: 0.3.0
- federation: 0.1.0
- files: 1.5.1
- files_pdfviewer: 0.8.1
- files_texteditor: 2.1
- files_trashbin: 0.9.0
- files_versions: 1.3.0
- files_videoplayer: 0.9.8
- firstrunwizard: 1.1
- gallery: 15.0.0
- notifications: 0.3.0
- provisioning_api: 0.5.0
- systemtags: 0.3.0
- templateeditor: 0.1
- updatenotification: 0.2.1
- user_external: 0.4
Disabled:
- encryption
- external
- files_antivirus
- files_external
- files_sharing
- user_ldap


#9

As this is a known bug and everything is currently discussed in https://github.com/owncloud/core/issues/25557 i'm closing here. Please follow the discussion there until a solution/fix is provided there.

If disabling the files_sharing app doesn't work (people have also reported that at the link) revert to your backup before you have upgraded to oC 9.1.0 for now.


#10