Failed upgrdade - Updates between multiple major versions and downgrades are unsupported

81x-eol
upgrade
help

#1

Hello,
I ended up with this error when I executed "sudo apt-get update && apt-get upgrade". I had an old oC with version 6-something before.
I followed the instructions here and felt safe since there should be Migration Test that prevents this to happen.

www-data@hp1:~/owncloud$ ./occ status
ownCloud or one of the apps require upgrade - only a limited number of commands are available
 - installed: true
 - version: 8.1.9.2
 - versionstring: 8.1.9
 - edition:
www-data@hp1:~/owncloud$ ./occ upgrade
ownCloud or one of the apps require upgrade - only a limited number of commands are available
Set log level to debug - current level: 'Debug'
Exception: Updates between multiple major versions and downgrades are unsupported.
Update failed
Maintenance mode is kept active
Reset log level to 'Debug'

The first time I executed "occ status" I got the error that the www-data user wan't available but that has been resolved by creating a shell for the user.


Confused newbie. Web Interface Says Its about to update then fails
#2

Hi,

as the message is pointing out you can't skip a major versions (Major versions are 7.0, 8.0, 8.1, 8.2, 9.0, 9.1) during the upgrade.

Documentation on how to do a correct upgrade when using the packages are available here:

https://doc.owncloud.org/server/9.1/admin_manual/maintenance/package_upgrade.html#upgrading-across-skipped-releases

So you need to first upgrade to the next major version (see config/config.php for the current version) first.


#3

Thank you for the help.
I had to do a manual upgrade at the end.
https://doc.owncloud.org/server/8.2/admin_manual/maintenance/manual_upgrade.html


#4

Hi,

if you're mixing packages and manual upgrades you will face issues sooner then later.

So please make sure that the current installed ownCloud version is matching the version provided by the used repository. If this is not the case your installation will fail as the newer version will get overwritten by the previous major version.


#5

Thanks for another very fast reply!
Where is this "latest version" stored? Why does my oC believe it is on latest version?
I have done manual upgrade to 6.09, 7.0.15 and now 8.0.15 and I still get this that is is on latest version when I try a "Release Channel install".

Reading package lists... Done
pelu@hp1:/var/www/owncloud$ sudo apt-get install owncloud
Reading package lists... Done
Building dependency tree
Reading state information... Done
owncloud is already the newest version.
The following package was automatically installed and is no longer required:
  libmpdec2
Use 'apt-get autoremove' to remove it.
0 upgraded, 0 newly installed, 0 to remove and 9 not upgraded.
pelu@hp1:/var/www/owncloud$

I'm currently on 8.0.15 after

www-data@hp1:~/owncloud$ ./occ upgrade
Set log level to debug - current level: 'Debug'
Turned on maintenance mode
Checked database schema update
Checked database schema update for apps
Updated database
Disabled 3rd-party app: calendar
Disabled 3rd-party app: contacts
Disabled 3rd-party app: documents
Disabled 3rd-party app: search_lucene
Updated <files_pdfviewer> to 0.7.1
Updated <activity> to 1.2.2
Updated <files_sharing> to 0.6.2
Updated <gallery> to 0.6.1
Turned off maintenance mode
Update successful
Reset log level to 'Debug'
www-data@hp1:~/owncloud$ ./occ status
Array
(
    [installed] => true
    [version] => 8.0.15.1
    [versionstring] => 8.0.15
    [edition] =>
)

#6

Exactly because of:

Your repository setup thinks you're on a newer version where you're actually on a far less recent version. If you want to fix this issue you need to manually continue upgrading your current version to the one:

apt-cache policy owncloud

is showing.


#7

ok, that was a great command!

So it looks like I have anually upgraded a bit to far now :confused:

www-data@hp1:~/owncloud$ apt-cache policy owncloud
owncloud:
  Installed: 8.2.7-2.1
  Candidate: 8.2.7-2.1
  Version table:
 *** 8.2.7-2.1 0
        100 /var/lib/dpkg/status
     8.0.15-2.2 0
        500 http://download.opensuse.org/repositories/isv:/ownCloud:/community:/8.0/xUbuntu_16.04/  Packages
     6.0.1+dfsg-1ubuntu1.2 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
     6.0.1+dfsg-1ubuntu1 0
        500 http://se.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
www-data@hp1:~/owncloud$ ./occ status
  - installed: true
  - version: 8.2.8.2
  - versionstring: 8.2.8
  - edition:

#8

No, that should be fine now. Afterwards you can replace the 8.0 repository from download.opensuse.org with the 9.0 one available here (i wouldn't go for 9.1 until 9.1.2 is released):

https://download.owncloud.org/download/repositories/9.0/owncloud


#9

Fantastic. Worked like a dream. I really appreciate the support!

www-data@hp1:~/owncloud$ ./occ status
ownCloud or one of the apps require upgrade - only a limited number of commands are available
You may use your browser or the occ upgrade command to do the upgrade
- installed: true
- version: 9.0.5.2
- versionstring: 9.0.5
- edition:
www-data@hp1:~/owncloud$