HEADERS on invalid Stream - ownCloud 10


#1

Hey there,

there is not much to reproduce as i don’t know what i am doing wrong, but i will give you all the information i have.

I rented webspace at a provider (ud media) and used their “software installer” to install owncloud. It worked right away.

But here’s the problem:
first i got the following message:
“HEADERS on invalid Stream”

since two day i get this one:
“HPACK decompression failed”

When does this happen?
i tried to synchronize mostly.pdf and odt. files to my webspace. They have really long filenames, such as: “Do you get What you paid for? An examination of products advertised as green tea leaves.pdf”
Maybe this is the problem? I really can’t reproduce the error. It seems like it happens at random, because some files get synchronized and others not.

Version:
ownCloud 10.0.10 (stable) (server)

Client:
ownCloud version 2.4.1 (Linux Mint)

I am very sorry if my explanation is not that good… i am a beginner in this type of thing and i am happy with every help.

best wishes!


#2

Hey,

maybe it could help if you try to use a recent version (Desktop Sync Client 2.5.1 released).

I’ve searched a little bit around via google and found the following below which could be also relevant:

https://bugreports.qt.io/browse/QTBUG-67469


#3

I am having the same exact issues. Just installed ownCloud at my shared hosting provider (DotEasy). Using the latest MacOS desktop client. Uploads result in the same two errors you are receiving. Except I’m uploading photos with simple file names like DSC00307.JPG (not pdfs with long file names, like you.) So clearly this has nothing to do with long file names.

Did you ever find a solution?


#4

Having the exact same problem and can’t figure out what’s wrong. The only thing I know is that we added a reverse proxy in front of the actual owncloud server a few days ago. The issues seem to have started then.
However, when I try synchronizing files myself, I don’t have a problem, only other people are reporting this error to me.
I have nothing related in either webserver or owncloud logs.


#5

Hey,

this looks to me like a quite good starting point where to look for the issue. Maybe that reverse proxy is injection / adding additional but unexpected data (HEADERS on invalid Stream) while transferring the data to the ownCloud server or similar?

Or there is some bug in the reverse proxy server itself (e.g. in conjunction with HTTP/2) which wasn’t there on the web server running ownCloud?

Or the reverse proxy is now supporting HTTP/2 which isn’t supported by web server ownCloud is runnig at and your version/variant of the ownCloud sync client isn’t using QT 5.11.0 which seems to have this bug here fixed:

But generally i think all leads to this bug in QT in conjunction with HTTP/2 enabled on the web server. Maybe:

and

have both in common that they are not using this recent QT version 5.11.0? Could be also possible that the same is valid for the Windows and Linux client as well?


#6

Hi, we finally found the issue. It was actually right there in the nginx error logs but I hadn’t seen it yesterday.
The problem was the default body size for nginx is only 1Megabyte. Increasing client_max_body_size solved the problem for us.

(And I had already disabled http2 earlier).


Can't upload files bigger than 1MB with Android App
#7

Hey,

nice that you have found the issue here.

It seems this is even mentioned in the documentation for file uploads but i think its strange that the desktop client behaves like this.

https://doc.owncloud.org/server/administration_manual/configuration/files/big_file_upload_configuration.html#nginx


#8

Regarding the HTTP2 bugs in Qt, I’ve created https://github.com/owncloud/client/issues/6968