Including/sending a share into my owncloud problem


I’ve a 10.4.1 Owncloud-server running an a Debian machine. Works fine, no problems.

Than there is a Nextcloud-server (managed by my kids school).

I used “add to your Nextcloud”.

This worked, now I have the folders from the Nextcloud in my Owncloud and I can navigate thru.

But if I try to access a file, I get “Service Unavailable”.

Yes, I try to link Nextcloud with Ownlcoud, but I think both using same standards (like webdav), so where is the problem?

Any ideas?


i don’t think that this is a topic for the “Development” category which is AFAIK used if you want to do development for ownCloud itself or it’s apps. Maybe you could edit the topic to use the “Server” category?

Related to your question i think you could find some hints in the log files of the ownCloud and / or the Nextcloud server. Maybe there are also some incompatibilities between both.

I think there could be also some bugs in one of both causing this problem. For example ownCloud 10.5.0 is recent but you’re using 10.4.1, maybe the Nextcloud server has also an older version with some known bugs?

Sorry, if I posted to the wrong channel. But I think it’s a bug and not a configuration-issue.

Updated my Owncloud-server to 10.5.0. The Nextcloud-server version is not accessible for me.

After upgrading my Owncloud-server, the error persists. Still no possibility to open files on remote cloud which is “linked” in my cloud. I can see all files and folders, I can open folders. But I can’t open/download files.

best regards


i think you should be able to get the version of the remote system by appending status.php to the URL (like e.g.

But i still think that you need to have access to the log files of both instances to check why the issue happens, without it i don’t think that anyone can tell you something about your problem. :frowning_face:

Thanks for the hint with status.php. Nextcloud-server has version 19.0.3

In my logs there are no entries - and yes, I’ve activated debug in config.php

@enzephalon I know that is cannot help you with your issue, but unfortunately I only can confirm that is doesn’t work at all. I’ve checked in a similar situation like you, accessing a shared folder on nextcloud server, where I should have full access. NO WAY.

Deleting an existing file works w/o visible errors, everything else fails.

[UPD] It works the other way. Federated share from ownCloud to nextcloud, no problem with it.

1 Like


maybe there is indeed an incompatibility between both? I think such a connection probably never was tested, maybe a bug report should be created for the ownCloud people?

Yes, maybe. But I doubt.
I’ve just tested again, this time in a pure ownCloud environment. Here is works well, so why care?

1 Like

Could you try a direct remote share?

In the nextcloud server there should be a sharing part where you can share with users and groups. You should be able to share with a remote user using something like youruser@, assuming you have a valid certificate that can be recognized by everyone (such as one from letsencrypt)
If the share is properly sent to your ownCloud server, you should be able to accept the share in your ownCloud account.

I don’t want to crush your dreams but I doubt this will be useful. I’m not surprising anyone saying that ownCloud is currently very focused on customers, and I doubt customers are or will be affected by this. Furthermore, this isn’t a trivial issue that someone can sneak a fix for it.
We’re talking about weeks dedicated just to know where the problem is between those 2 particular versions. Add time to include compatibility, possible interferences with apps, understanding whatever nextcloud is doing… It’s easy to reach a month.
I doubt ownCloud wants to spend a month-worth work for free…

Unless you can provide undeniable proof that ownCloud broke something (maybe it worked in a previous version), I doubt ownCloud will make a move, and this will take a lot of your time.
Anyway, if you’re confident with your PHP skills, “PRs are welcomed”



In the nextcloud server there should be a sharing part where you can share with users and groups.

I’ve no user-account at the Nextcloud-server. There is only a shared directory. There I used the “add this to your Nextcloud” by typing in “” . After this, my Owncloud telled me about the introducing and asked for accepting this - so I did.
I’ve no more options in the Nextcloud.

@alfredb Thanks for your test. So it’s not my “fault” - it’s just does not work between Nextcloud and Owncloud - which is sad, but a bit of expected.


Well, it’s not that surprising but very unfortunate, to be honest. Since the fork, the two projects went more and more on separate ways.

1 Like