iOS 11 Files Support


#1

Are there any plans to natively support the iOS 11 Files app?


#2

We are working on it. You can track the status here: https://github.com/owncloud/ios/issues/905


#3

I would like to second this feature request. iOS client is still not fully integrated with File app in iOS 11/12. Indeed is possible to open files in ownCloud through the File app, but to do so, a pop up windows with ownCloud client is shown INSIDE the File app.
For comparison, DropBox and Google Drive iOS clients are fully integrated with File and could content is shown within File app with the native UI (i.e. without the popup window).

It would very nice to have full integration.


OwnCloud doesnt load my Files up on my iPad Pro
#4

It’s nice of you that you compare ownCloud with Google and DropBox :slight_smile:

The files app integration is planned for the near future.


#5

I would like to add to the statement by Dmitry: We decided to create a completely new iOS app. The app will be much faster, modern and of course 100% compatible with the FilesApp. We will soon reach the beta stage. If we reach this stage you are invited to take part in the test.

We are currently writing a blog post which will give you a good first impression soon.


#6

Great to hear!

How can we hear about the beta testing phase? and how to join ?

Looking forward for the new version integrated with FilesApp.

Thanks


#7

Today we published a blog article about the new app: https://owncloud.org/news/working-brand-new-ios-app-sdk/

You can register for the beta program here: https://testflight.apple.com/join/Oktj0iKv
-> Quick guide: After you have installed the Testflight App open the link in Safari Browser on your device.


#8

Hello I installed the beta version of Owncloud IOS App on my IPAD 6th, but I can not add my server. I sent some screenshots, as well as a video to the support team but no answer. Does anyone know why I could be having issues?
I basically add the server url, then owncloud recognizes it, and shows me the certifacate details, but then if I press “continue”, nothing happens. The only thing I can do is to cancel the process. I tried to check the logfile by going to the setting and share logfile, but when i click on logfile, the owncloud crashes and close itself.

Any ideas?

Thanks in advance


#9

I have the exact same issue.


#10

Sorry, seems I missed some of the feedback mails. What server version are you using? Could you send a test account to apps@owncloud.com?


#11

What server version are you using? Could you also send a test account to apps@owncloud.com?


#12

Just answered @JuanMa in the mail, but I’ll also post here:

I’m very sorry, but ownCloud 8.0 is end of life for a long time, and we can’t support the outdated architecture with the new iOS app:
https://github.com/owncloud/core/wiki/Maintenance-and-Release-Schedule

The new iOS app only supports ownCloud 10 versions and higher.

​​​​​​​I encourage you to upgrade your server version. Keeping software up to date is crucial for file integrity and security – if software is outdated, there can be unfixed bugs. That’s why you should always upgrade your software when there is a new version.
If you have any question or problem about it, check it in the open forum or post there whatever you need: https://central.owncloud.org/

I’d recommend to run your ownCloud server on an energy efficient Linux machine or Raspberry Pi and use your QNAP for storage.

To access the 8.0 ownCloud server from the iOS Files app, you could check the 3rd party apps I recommended here:
https://github.com/owncloud/ios/issues/941#issuecomment-382854594


#13

i’m on 10.x – away from my server for a while, so logs are difficult, but does that help?


#14

We’ll release a new beta build with TestFlight later today. It contains some fixes for redirects for example. If it’s not fixed with the next build, we should have a closer look. We have a debug logging feature of the settings screen. This could help investigating…


#15

Awesome, thanks :slight_smile:


#16

:rocket: build 83 is ready for testing