Mac client not synching all folders reliably

Hi there, I am currently running the current version of the Mac and Windows sync client against Owncloud Server running in a VM on Windows Server 2016. We use SMB connections through Owncloud for our offsite employees.

All of the Windows clients are synching correctly. The Mac clients often do not ever update a folder even when they say they are current which is an issue because of the 20 offsite employees we have, 18 of them are on Macs. When checking Owncloud via the web portal all folders are always current so this is definitively an issue with the Mac client. Any settings changes to the client or advice on how to proceed would be appreciated. We spent like 50 hours getting this fine tuned and this is the last bug left I need to resolve so I’d really hate to scrap this entire project because of it!

@Ben_Sobaje ownCloud can’t reliable detect changes on the mounted storage. A regular files scan could help:

With the ownCloud Enterprise Subscription, you can use additional tools to collaborate on windows network drives:

1 Like

Thanks for the response! You think I should execute this on the Mac clients? It looks like Cron is already set up on the Owncloud server and logging in to the web version of Owncloud or on Windows clients the sync are OK. It’s only the Mac sync that doesn’t work.

No, not on the Mac clients. You’ll need a new cron job for scanning on the ownCloud server.

If you navigate to a folder in the web UI, then the request for this folder on the external storage is made. But on the desktop client, nobody navigates to this subfolder.

Try the following: Find one of the folders that the desktop client doesn’t sync, then navigate to this folder in the web UI. The client starts syncing this folder a few seconds later.

1 Like

Got it, I will give that a shot and report back once one of my users is at a stopping point. Thank you so much for the help Michael!

Hey Michael, I think I may have gotten it set up but I don’t have a ton of Linux experience which I realize is not ideal but it is what it is!

I booted into recovery mode because that was the only method I found of getting a console. I then ran a find command for cron.php and found twelve of them in assorted /var/lib/ subdirs. I ran “crontab -u www-data -e” and I used nano to edit it. I then copied the list of twelve cron.php files with paths I found into it and made them scheduled jobs using the format from the cron link you provided above. I saved and used the default file name when I was prompted. I then typed reboot and the VM rebooted back into Owncloud.

Two questions if you would be so kind!

  1. Does this sound about right to you?
  2. Do you know if there is there a way to get to a console window from the Community edition VM without having to enter recovery mode?

Thank you so much for all of your help! I would like to paypal you a few bucks so I can buy you a beer or a cup of coffee or something to thank you for your help if you aren’t opposed to it.

OK well it looks like it’s working. Thanks! Coffee or beer offer still on the table :slight_smile:

I’m not sure what you mean with Community edition VM? Do you know where is VM was downloaded from?
The standard way of administrating Linux is through SSH, on a Mac there is a client pre-installed and on Windows you’d have to install a client.

This sounds a little bit like an appliance to me. You can find extensive documentation for it here:

Additionally how to set up a listener is detailed as well:

@michaelstingl I wouldn’t let that offer pass :wink:

Hot damn, I was so wrong about it working; it is doing the same thing it did before. It is the Univention appliance. Thank you so much for sending those links over. I didn’t see those.

I figured out the SSH thing on my own but I’m so lame with Linux.

I’m trying to follow the WND listener instructions but I can’t seem to find a copy of occ in any folder except the weird long docker folders. Should I just copy one instance of it into one of the other folders? At this point I’ve spent like 30 hours on this and I’m about at my wits end. If you are up for it I would pay you to help me do this @eneubauer

WND is an enterprise feature. If you have an enterprise subscription you should be able to contact the official ownCloud support, and they would be able to help you set this up.

So in the appliance WND documentation it shows how to run the occ commands with unvention-shell (this does some docker magic, to execute them in the right context), like so:

/usr/bin/univention-app shell owncloud occ

Oh dang, really? Shoot that’s rough. We don’t have an enterprise subscription. It seems unfortunate that the documentation didn’t really make that clear. I guess it’s back to the drawing board and I’m probably going to get fired :confused: Thanks for the help though.

Docs updated:

If it’s not that many files, you should find out to setup the additional cronjob for regular scanning.

1 Like

Got any tips for me? I worked on this for the last six days and I’m not any closer to making it work. Since it’s that Docker thing here’s the command I am using in crontab:

*/5 * * * * sudo /usr/bin/univention-app shell owncloud occ files:scan --all

I was trying to just run this command but I can’t figure out the path because I don’t understand how Docker works: * * * * * /usr/bin/php -f /path/to/your/owncloud/cron.php

I think I could make this work if I understood where to find cron.php.

Or, if there is documentation or you guys can give me some advice on how and where to use the filescan() I might be able to make that work.

If you setup a cron job, it will automatically start logging into the system log, read what it says, perhaps there is some error message.

You should probably just setup the cronjob for the root user and omit the sudo command at the beginning.

Have you tried running your command in a shell and does it do what it is supposed to do?