New installation on a web hosting - new folders not created

Is the double slash a problem?

Yes, I noticed too. Not sure. I have another server where everything works, and there’s no double slash… How would I fix that… I added another user yesterday and it also shows the double slash.

I guess it’s in my config.php, the data location ends with a slash. I’ll try to remove

Ah, I see. You have a trailing slash there.

The fix in config.php did not remove the double shash in user’s menu. I thing it’s in the database as well. I’ll search how to change the data store location properly.

Table ‘oc_accounts’, column ‘home’.

Thanks. I found an article. There’re multiple places

Unfortunately, fix to the path did not help, still not creating a folder…

Perhaps something was corrupted because of the wrong path. I’ll try to re-install the ownCloud later today and see if that helps.

BTW, some time ago, I also tried an installation with a data directory under public_html, but couldn’t bring it to a good state. After switching to a dedicated directory all the trouble went away. Just wanted to mention this.

Thanks. I started with a dedicated directory and when discovered that it’s not working, I moved to the owncloud one :slight_smile: My another instance is running with a dedicated directory, but I have full access there and configured by the instructions. Here I’m not sure if the default ownership settings with itk are sufficient for the owncloud. I’ll file a support ticket to my provider and see if they can figure that out.

I looks like there’s a bug in the web installer. I just installed it clean on my dedicated box with all proper permissions and also cannot create a folder! The same owncloud version is working on the same box after upgrade from version 9 without problems. I’ll try to compare configs to see the difference.

Yes, webinstaller shouldn’t be used anymore.

Gosh, would it be mentioned in the docs more obviously?.. Thanks for letting me know!

My provider is saying that creating a folder uses a call in the form

The MKCOL method is used and it is not standard requiring WebDAV over HTTP. Is that correct? Is there a workaround? How the folders are created during installation and new user creation? That’s very strange that some code of the application can create folders while some core functionality isn’t working.

I found a workaround here HTTP methods MKCOL and DELETE return error 501 Not Implemented, but it does not work for me.


from what i know ownCloud is using various additional HTTP methods besides GET/POST/PUT like MKCOL or PROPFIND etc. which are required for ownCloud to work correctly. If your environment doesn’t provide the required methods then i thin it could explain why you’re seeing this issue.

1 Like

Fully agree with @tom42. ownCloud depends on a working webdav base, including MKCOL.

Yep, I gave up on shared hosting and moved to a VPS. Everything works fine there. It wasn’t just obvious that these additional methods were removed by the provider. As I understand, they are standard for the Apache server.


from what i know support for the “extended” Methods like PROPFIND and so on are provided by ownCloud itself but can be easily blocked directly within the web server configuration like seen in e.g.:

Thanks. I might try, but I moved to a dedicated server without such limits, so I guess this topic can be closed for now.