No marketplace connection: cURL error 60

Hi,
when i try to open MARKET i get this:
No marketplace connection: cURL error 60: SSL certificate problem: certificate has expired

The SSL certificate it’s right and will expire in 11 January 2022

Hi,

That’s related to DST Root CA X3 Expiration (September 2021) - Let's Encrypt You have to update your OS packages.

1 Like

Hi,
Any chance of elaborating a bit?
I’m currently using Owncloud in a docker container
I’ve tried removing the certificate from both Ubuntu server and Owncloud container
and even allowed curl -k and still no go
I ran sudo -u www-data php occ market:upgrade market
and get market: No marketplace connection: cURL error 60: SSL certificate problem: certificate has expired

Any help what to do?

What’s your setup? You use the official Docker container from Docker Hub? What version? What’s your OS/version?

Currently using Ubuntu 20.04 with official docker container from Docker Hub and and has been updated over time to the latest version 10.8

Please post the output from curl -LI https://marketplace.owncloud.com executed on the host as well as from inside of the container.

****** Ubuntu *******

HTTP/2 200
accept-ranges: bytes
cache-control: max-age=0, no-store
content-language: en
content-security-policy: default-src ‘self’; img-src minio:9000 piwik./owncloud.com storage.marketplace./owncloud.com marketplace-storage.int./owncloud.com api.-adorable.io data: ‘self’;script-src s./ytimg.com www./youtube.com piwik./owncloud.com
https://www.-google.com/recaptcha/ https://www.-gstatic.com/recaptcha/ ‘self’ ‘unsafe-inline’ ‘unsafe-eval’ data:;style-src fonts.-googleapis.com cdn.-jsdelivr.net ‘unsafe-inline’ ‘self’;font-src fonts.-gstatic.com fonts.-googleapis.com cdn.-jsdelivr.net ‘self’; frame-src www.-youtube.com appcenter.-software-univention.de *.owncloud.com https://www.-google.com/recaptcha/
content-type: text/html
date: Thu, 18 Nov 2021 17:13:31 GMT
etag: “4ac-5b8c924081500”
last-modified: Wed, 13 Jan 2021 14:41:56 GMT
referrer-policy: strict-origin-when-cross-origin
server: Apache
strict-transport-security: max-age=315360000; preload
x-content-type-options: nosniff
x-frame-options: SAMEORIGIN
x-xss-protection: 1; mode=block
content-length: 1196

===Container on Ubuntu===
HTTP/2 200
accept-ranges: bytes
cache-control: max-age=0, no-store
content-language: en
content-security-policy: default-src ‘self’; img-src minio:9000 piwik.-owncloud.com storage.-marketplace.owncloud.com -marketplace-storage.int.owncloud.com -api.adorable.io data: ‘self’;script-src -s.ytimg.com -www.youtube.com -piwik.owncloud.com https://-www.google.com/recaptcha/ https://-www.gstatic.com/recaptcha/ ‘self’ ‘unsafe-inline’ ‘unsafe-eval’ data:;style-src -fonts.googleapis.com -cdn.jsdelivr.net ‘unsafe-inline’ ‘self’;font-src -fonts.gstatic.com -fonts.googleapis.com -cdn.jsdelivr.net ‘self’; frame-src -www.youtube.com -appcenter.software-univention.de *.owncloud.com https://www.-google.com/recaptcha/
content-type: text/html
date: Thu, 18 Nov 2021 17:14:09 GMT
etag: “4ac-5b8c924081500”
last-modified: Wed, 13 Jan 2021 14:41:56 GMT
referrer-policy: strict-origin-when-cross-origin
server: Apache
strict-transport-security: max-age=315360000; preload
x-content-type-options: nosniff
x-frame-options: SAMEORIGIN
x-xss-protection: 1; mode=block
content-length: 1196

Sorry for the bad links. Had to break them because I couldn’t “post a message with more than 2 links”

Hi @SaGal,

I don’t know whether this will work for your system, but here is what I’ve done to get the marketplace back.

  • Edit the file resources/config/ca-bundle.crt
  • Search for the certificate “DST Root CA X3”
  • Delete this certificate from the file

After this, the curl error at marketplace was gone, the app is working as before.
You might give it a try.

1 Like

Hmm, I really wonder why this is needed or fix the problem for some. We run several of oC 10.8 instances (Docker and host-based) on our own, and we have never seen this issue. If you are running an older version of oC, this could make the difference as the bundle may not include a new Let’s Encrypt ISRG Root X1 CA, but 10.8 should just work :thinking:

Keep in mind that manually editing the resources/config/ca-bundle.crt file may cause integrity check issues.

I did a quick test and for the docker images, I’m still not able to reproduce it. Back to owncloud/server:10.0 the occ market command works without any issue for me.

It was working, until a few weeks before. Unfortunately, this was the one and only change that got the problem vanished. Of course, I know that this is just a workaround, but at least, I can continue to install and update my apps again. BTW, due to some patches, I have to deal with the integrity issue anyway.

Thank you very much!!
This indeed worked

Hi,

I’m getting the same error.
I have the latest version of QNAP OS 5.0…0.1986, with OwnCloud QNAP App version 10.0.10.1.

The app works fine, except that I get the error when I open Marketplace.

curl response is:

Please help me to fix the issue.

Kind regards,
Ilia