Not able to change owncloud data folder to /home/owncloud,


#1

Hello

Owncloud data issue in Centos 6.7

When i am changing ownlcoud data folder from /root to /home via config File it is giving an error on web link

“Data directory is not writable by Owncloud”

I have given apache owner to that folder but the issue remains

i have also created a symbolic link for data folder but then too issue not solved

Is there anything that i am missing?


#2

Yes. There is a doc on this topic.

https://doc.owncloud.org/server/10.0/admin_manual/maintenance/manually-moving-data-folders.html


#3

I have tried the same except the SQL queries, but the issue remains as i am not hands on to SQL queries


#4

This is not enough, the db needs to be updated.


#5

Sounds too general. What about the directories below, config etc? Ownership is only one part, permission the other one.

Please take this into account:
https://doc.owncloud.org/server/latest/admin_manual/installation/installation_wizard.html#post-installation-steps-label


#6

ok will check with this once and let you know

–Raj


#7

Hello

i have done as per both the links given, but still issue remains same

please help me on this…


#8

You should give more details, otherwise nobody can help.


#9

This error is coming when i am changing Data directory path in config.php file

as per the links i have created a symbolic link between /var/www/html/owncloud/data to /home/owncloud, but after changing the data path in config this error comes

My concern is to make /home/owncloud/data directory usable rather then /var/www/html/owncloud/data


#10

But you still give no info about the current situation. Ownership and permissions of the two directories in question. Nobody can help here.:roll_eyes:


#11

I have installed owncloud 10 in centos 6.7 installation path is /var/www/html/owncloud, this is having apache user and group ownership and 775 as permissions
owncloud is getting accessible via browser successfully and the database type is mysql
but as /var/www/html/owncloud is located in root mount which is of max 50 GB i need to change data directory to /home

Now i have created a symlink from old path to /home path and also changed data path in config and mysql (via phpMyAdmin)

httpd service restarted

now when i access owncloud on browser i am getting

your data directory is not writable by owncloud


#12

Why do you need a symlink, when you have changed the path in config and db?


#13

even after canceling the symlink and changing path in db and config the issue remains same


#14

ls -la /home/owncloud | head -n 2


#15

image


#16

IIRC, http user for centos is apache. So why do you expect it should be allowed into roots directory?


#17

Should i change owner of home to apache?


#18

Not of /home (!), but /home/owncloud and everything below.


#19

done for /home/owncloud whole directory
httpd servive restarted
but then too its showing that data directory is not writable

image


#20

grep datadirectory /var/www/html/owncloud/config/config.php | sed “s/[’,]//g” | cut -d’ ’ -f5 | xargs ls -la | head -n 2