OC 10 and Marketplace

marketplace

#1

Hi,
I just upgraded to the latest version (10.0.0.12) and I realized that, almost all my applications are vanished.
Documents, addressbook, tasks, calendar, ownnotes etc.

I tried to enable at least calendar/addressbook but I did not find them under the Disabled apps.
I also tried to start the Market app, which seems running, there is no error message, but I only got a Market/Categories small box on the page and there are no categories nor apps.

My question, is it my fault because I missed something or it is a bug or it is valid because there are no apps for 10.x yet?
Thank you!
István


#2

Hi,

as you can see on [1] there are already quite a lot apps published at the marketplace.

If you don't get any of the marketplace apps showing up in your ownCloud installation then most likely the connection to https://marketplace.owncloud.com doesn't work or similar. Your logfiles (PHP error log, data/owncloud.log, etc.) might tell you more.

[1] https://marketplace.owncloud.com/


#3

And in which file must I insert the correct url?


#4

The marketplace is already in the code, you don't need to put the URL manually.


#5

@ tflidd:
But when I try to upgrade from a 9.1.4 version the Marketplace won't be found. :unamused:


#6

I have the same problem as the OP. I upgraded from 9 to 10 and had to disable a few apps using occ app:disable because the updater failed when it couldn't update them (gallery, PDF viewer).

Afterwards I wanted to reinstall them, but the "Apps" in the top left corner menu was gone. Instead, there is now "Market". Opening the market however just results in a pretty empty page with a loading circle animation which endlessly spins.

The owncloud log shows a message when that happens: "url":"/index.php/apps/market/apps","message":"array_map(): Argument #2 should be an array at /var/www/owncloud/apps/market/lib/Controller/MarketController.php#221"

There's also two errors in the developer console:

GET https://foobar/index.php/apps/market/has-license-key 404 (Not Found) in xhr.js?14ed:177

and

TypeError: Cannot read property 'length' of null in vue.runtime.esm.js?a427:519 
    at VueComponent.render (eval at <anonymous> (market.bundle.js?v=9cc73684cba861c61bac8fd54a19340a:1), <anonymous>:29:25)
    at VueComponent.Vue._render (eval at <anonymous> (market.bundle.js?v=9cc73684cba861c61bac8fd54a19340a:1), <anonymous>:3899:22)
    at VueComponent.updateComponent (eval at <anonymous> (market.bundle.js?v=9cc73684cba861c61bac8fd54a19340a:1), <anonymous>:2435:21)
    at Watcher.get (eval at <anonymous> (market.bundle.js?v=9cc73684cba861c61bac8fd54a19340a:1), <anonymous>:2774:25)
    at Watcher.run (eval at <anonymous> (market.bundle.js?v=9cc73684cba861c61bac8fd54a19340a:1), <anonymous>:2844:22)
    at flushSchedulerQueue (eval at <anonymous> (market.bundle.js?v=9cc73684cba861c61bac8fd54a19340a:1), <anonymous>:2611:13)
    at Array.eval (eval at <anonymous> (market.bundle.js?v=9cc73684cba861c61bac8fd54a19340a:1), <anonymous>:651:14)
    at nextTickHandler (eval at <anonymous> (market.bundle.js?v=9cc73684cba861c61bac8fd54a19340a:1), <anonymous>:598:16)
    at <anonymous>

Seeing this 404, I tried opening that URL in the browser, and the page said {"message":"No license key configured."} (and threw a 404).

I also see "Add API key" and "Start enterprise trial" buttons in the lefthand navigation of the market page. Does this mean I need an API key to be able to install apps from within the owncloud installation, even in the open source edition?


#7

Are you an Enterprise User?


#8

No, community edition. Hence my confusion.


#9

can you check if the market app is installed? this is an occ command

https://doc.owncloud.com/server/10.0/admin_manual/configuration/server/occ_command.html?highlight=occ


#10

# sudo -u www-data php /var/www/owncloud/occ app:list
Enabled:
  - comments: 0.3.0
  - configreport: 0.1.1
  - dav: 0.3.0
  - federatedfilesharing: 0.3.1
  - federation: 0.1.0
  - files: 1.5.1
  - files_external: 0.7.1
  - files_sharing: 0.10.1
  - files_trashbin: 0.9.1
  - files_videoplayer: 0.9.8
  - firstrunwizard: 1.1
  - market: 0.2.2
  - notifications: 0.3.1
  - provisioning_api: 0.5.0
  - systemtags: 0.3.0
  - templateeditor: 0.1
  - updatenotification: 0.2.1
Disabled:
  - encryption
  - external
  - files_antivirus
  - files_versions
  - theme-example
  - user_external

also:

version	10.0.3.3
versionstring	10.0.3
edition	Community
productname	ownCloud

#11

This looks quite similar to https://central.owncloud.org/t/market-will-not-load-loading-icon-just-spins/9269


#12

Well, what can I say -- the answer was in this post. Commenting out the appstoreurl config line made it work.


#13

Saved me hours .... thanks for sharing the solution!