OC 10 - Cannot create folder/file with Umlaute


#1

"Could not create folder" error when using Umlaute

I installed ownCloud 10 Server on my Raspberry Pi 3 and i am using the data directory on an USB with 32GB. Everything is working fine, but creating folders or uploading files containing Umlaute like "ä", "ö" or "ü" does not work. Only the error message appears. Locales are configured with de_DE.UTF-8 (also tried en_US.UTF-8). I can create files with Umlaute anywhere just not on the USB.

Locales output:
LANG=de_DE.UTF-8
LANGUAGE=
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=


#2

Hi,

can you provide some information about your setup?

can you post the error message that occurs when you are trying to create a folder with umlaute?


#3

If i try creating a folder on the USB named "ä" it gives this message:

mkdir: cannot create directory '\303\244': Invalid argument

Raspberry uses Raspbian as operating system.
I am running ownCloud 10.0.7 for debian 9 (Linux packages).


#4

Is the USB NTFS / FAT formatted?


#5

The USB is formatted as FAT32.


#6

So i think this is your issue then. ownCloud is only running on Linux-Operating systems so every data storage needs a linux partition like ext3/ext4 and similar.

Addition:

Just found the statement of @pmaier1 about this here: https://central.owncloud.org/t/your-data-directory-is-readable-by-other-users/10415/6


#7

Thanks! I formatted to ext4 and it is working fine now :slight_smile: !