ownCloud 10 multiple page not found errors using sFTP


#1

Hi all

I am a total ownCloud newb, we had v9 working without issue, howeve; since I am a noob and decided to do the easy v10 install I am having all sorts of issue:

when I upload a file using an sFTP connection, I get a "target folder does not exist" message, it works with small files.
I get the same error message when I upload to the default docs folder, regarding the sFTP folder.

I am receiving an intermitant page not found message in my firewall for:
"domain.com/owncloud"
"domain.com/owncloud/ocs/v2.php/apps/notifications/api/v1/notifications?format=json"

my cpanel has multiple "public_html/owncloud/data/.htaccess pcfg_openfile: unable to check htaccess file" errors the .htaccess has 644 permissions, I believe 640 is recommended, so less secure.

the ownCloud log has a php5-intl message, I have this being installed tonight, the error indicates it is highly recommended.

I am using sqlite as I could not figure out how to mount a mysql database


#2

I think something which worked and stopped working after an upgrade should be reported to the bugtracker.


#3

I cant say for sure that v9 would have been working on the new Doman. I am ready to put v9 on to try it


#4

I just received this page not found error in my firewall
https://domain.com/owncloud/ocs/v2.php/apps/notifications/api/v1/notifications?format=json


#5

just in case anyone else comes across this post, it seems to be similar to https://central.owncloud.org/t/sftp-connection-closes-after-each-folder-listing-thrashing-owncloud-10-ubuntu-14/8839.

my external sFTP was closing every 20 seconds, causing the eventual folder not found message.

using FileZilla to connect to sFTP, I received a certificate warning then connected, it disconnected after 20 seconds and then reconnected till completions.

OwnCloud sFTP connection would create a .part file, at the 20 second mark it would create another .part file, which it would do a couple more times and then stop.

seems to be an sFTP issue within OwnCloud.