OwnCloud client for Windows crashes after first boot

Hi, all!

I have an HP Pavilion laptop with the latest Ryzen 5 5000 series and Windows 10 Pro with all latest updates. I installed the latest version of OwnCloud Desktop client software (version 2.8.2) and every time after the first boot of the OS the client crashes. After manual restart of the client, it works excellent.

Even if I turn off the loading of the client on the OS startup and launch it manually after Windows is loaded, it still crashes. But on the second manual launch, it works fine.

What is interesting, we have 3 other the same laptops with approximately the same set of software, but
with Intel CPUs and there is no that problem.

I tried to search for the solution in Google, but all the advices are about switching off automatic checking of updates of the client. However, I can’t find where to do it.

Have anybody experienced a similar problem? How did you solve it?

Thank you.

Could you test with a 2.9-daily build?
https://download.owncloud.com/desktop/ownCloud/daily/2.9/win/?sort=time&order=desc

In case it still crashes, please submit the crash report, and post the crash ID here.

@michaelstingl, thank you for your reply.

I did exactly what you said and OwnCloud client crashed again. I sent the crash report. Crash report ID is b6283ecd-2b0f-4c0b-907b-331314e2497d. Could you understand what is wrong there?

Thank you.

Hi can you make sue the folder ownCloud does exist in your home folder?

Hello, @TheOneRing!

Yes, the folder of ownCloud exists in the user’s home folder - C:\Users\User_name. All files are there. The user is also logged in under the User_name name. And the ownCloud client itself was installed under this User_name account.

As I wrote before, the ownCloud client crashes only during the first launch. On the second launch, it works perfectly if you do not reboot the laptop. Then it crashes again and requires the second launch.

The home folder is located on that device and not mapped or in any way special?

Yes, the home folder is located on that device. It was a standard installation. Like on tens of other computers in our company.

The new and improved crash reported sadly messed up the encoding of the log, now fixed on master.
Sadly this means the error message got scrambled.
The client fails to register the sync root with the virtual file system.
We’ve seen this happen when:

  • Ussers where over eager and removed the sync root(user/ownCloud folder) on a client update.
  • The folder is lacking write permissions due to other applications interfering.
  • The folder is located on a network drive.

The first and the third possible reasons are not our cases, because the ownCloud folder is on the device.

The second reason is possible. But why does the ownCloud client crash only on the first launch and start successfully on the second attempt?

@TheOneRing, is there anything else I can do to provide you correct or more detailed logs?

Could you install todays 2.9 build, then submit the crash report again?

Good morning, @michaelstingl!

I have just installed yesterday’s build. It’s crashed after the start, I sent a crash report, the ID is 97152c9b-7481-4560-b408-ed3edd9385d5. Is there any clue on the reason in the report?

I’m sorry, the log now is better but for the actual error message we still got
06-14 10:13:59:572 [ fatal default ]: Error registering StorageProvider for C:\Users\������������������\ownCloud �������� � �������.

This is due to another encoding issue we got.
I’m sorry could you try it again tomorrow with the latest nightly?

Yes, sure, I will and write here about the result.

Hi, @TheOneRing!

Crash report ID is c69200d1-066b-418b-ba62-653fb4eb99bd. Now there is no problem with encoding. And it is clear that the reason for the crash is that something blocks access to the ownCloud folder of the user on the first launch. But how to understand what exactly is this? And why nothing block the folder on the second and further launches?

@michaelstingl, @TheOneRing, I don’t know what is so special in the build ownCloud-2.9.0-daily20210615.4396.x64.msi, but after the first crash which happened after it was installed, the ownCloud client does not crash anymore. I rebooted the laptop and the ownCloud client started without any problem. We have changed nothing in the system on the device. Therefore I think, something was updated in the build. In any case, it seems for now I can declare that my problem was solved.
Thank you for your assistance!

I’m not aware of a change that could have fixed the crash…
But seeing proper logs in the crash reporter makes me more than happy even so no crashes would be even better :smiley:

:slight_smile: :slight_smile: :slight_smile:
That is also good. Despite the problem is seemed to be solved, do you have any ideas, what caused crashes before?

So. Just for those who will face the same problem, I am writing here this text.

Actually, the problem was not solved after the build ownCloud-2.9.0-daily20210615.4396.x64.msi was installed. My previous post about it was wrong. The ownCloud client proceeded to crash on the first launch and successfully started on the second try. The crash reports said that the fatal error happened when the ownClient client tried to register the ownCloud user folder. This action got access denied. In the repost it looked the following:

Date time [fatal default]: Error registering StorageProvider for C:\Users\user_name_was_here\ownCloud Access denied.

There was no explanation why exactly denied the access. But my guess was that Kaspersky Enterprise Security (KES) which is used on this computer was the reason. Unlike other devices where we use ownCloud and KES, on this device, KES was installed before ownCloud. I deleted KES and reinstall it again. After this, the problem has gone.

I managed to reproduce the same problem (installed KES first and then installed ownCloud) and fix it the same way (remove and reinstall KES) on another computer. So it seems in my case that was the reason.

Thank you to everyone who assisted me!

1 Like