Owncloud Linux client getting timeout, Raspberry Pi 3 server crashing

I’ve been having some troubles lately, and I don’t really know if the problem is with the desktop (Linux) client or the Raspberry PI. So, please, bear with me with a long(ish) explanation:

  • The Server is a Raspberry Pi 3 with an external HDD and the official power supply. It has other several applications installed running for several years more or less smoothly.

  • My local network is comprised from a Windows 7 machine (Desktop, 2.5.1) and a Xubuntu 18.04.3 LTS (Laptop, 2.6.0).

The process that hangs the Raspberry Pi is as follows:

  1. Sync a (over) 200MB file from Desktop to Server. File syncs correctly.
  2. Trying to sync the file from Server to Laptop. Server stops responding, I get a “timeout” error and am forced to hard reset the pi.

It seems its a bit of correlation with a “low space” problem in the SD card, as doing dfpoint me towards a 99% usage. Writing

sudo du -h / --exclude /home | grep -P "^[\d\.]+M|G\s+" > /<accessible-path>/du-rootfs.txt

led me to

1,2G	/var/cache/lighttpd/uploads
1,2G	/var/cache/lighttpd
1,2G	/var/cache

Which makes me to think that, somehow, Owncloud is trying really hard to send the file to my laptop, but it crashes when trying to, and the file stays on the cache “uploads” folder somehow. Just remind that we are talking about Desktop trying to sync from Pi, this is, downloading a file.

It seems the “low space” is a dead end, as the problem is that the pi timeouts when trying to move the file to the laptop. And I’m completely lost on where can the problem be. My .user.ini file is the default one (max file sizes of 513M), and the file that gets “locked” while trying to sync is 200MB.

As I said, this same installation has been running for years with not a lot of issues. I haven’t done anything weird or special lately (Besides adding a lot of “big” files to the folder), and the installation is not open to the internet, only to my local network. Any ideas? Thanks!

Just to be clear, your ownCloud is running on lighttpd? Unfortunately I have no experience with this web server, and according to the docs it is not supported for ownCloud. So you’ll probably have a hard time finding other people with similar problems, as nobody is using it.

Additionally I would say this is actually more of a server issue if it’s crashing. In order to be able to efficiently help you we need the post template filled out. Also have a look in all the different logs and see whether there are any obvious error messages.

So you can’t even log in via SSH any more?

1 Like

My problem is that I wasn’t really sure of what was going on. I thought the problem was related to the linux client because the problem came when I tried to sync from pi to Linux (And from Win to Pi had no issue).

It seems another problem I’m facing is with the webserver configuration, as I originally installed an Apache server… but somehow is not working anymore. And I just realized it. I’ve been doing some digging and maybe the culptrit is a pihole installation (Which seems to install lightppd because fuck you).

Well, I can say I have learned a bit with your answer, and that it looks like the culptrit is not owncloud. Gotta love computer science. Thanks!

EDIT: Yeah, uninstalling Pi-Hole (and taking away the lightppd and re-enabling the apache server fixed the issue. Yay, learning the hard way!)

1 Like

You just have to understand that you can only run one service per port. So if lighttpd is listening on port 80 and 443, you can’t have apache listening on the same ports.

I don’t know anything about PiHole installations, but it seems like it is incompatible to run alongside an ownCloud installation. You might be able to set up a reverse proxy in front of both, which routes the requests accordingly, but that is definitely an advanced configuration.

1 Like

Yeah, the problem is that I thought the installation detected the apache and just went along the way. There was nothing telling me that pi hole was also installing a different webserver until I run in these problems.

Right now what I’m looking for is some guide to install pi hole on an apache 2 server (As at least, both Owncloud’s web interface and Pi Hole’s were working with no issues). I guess I just got another Christmas project…

1 Like