OwnCloud support for PHP 8.X

I am using Own Cloud 10.6.0.5.
This version does not support PHP higher than 7.4 and for sure not 8.X.
I need to upgrade to a version that supports PHP 8.0

Which version does support PHP 8.X?

Thanks theaterimpariserhof

There is currently no planned ownCloud support for any PHP after 7.4.

Our provider will switch on the 01rst of February to PHP 8.X. So we really are in deep trouble. Is there a beta I could install? Or is the only way to switch to nextcloud or similar product?

Thanks

Regardless of my opinion on the matter, ownCloud have repeatedly held the unwavering position they will only support end of life PHP 7.4. No newer versions will run ownCloud.

You have two weeks to either find a new provider for your ownCloud, persuade your current provider to keep PHP 7.4 for ownCloud, or migrate to another solution.

2 Likes

Thanks. This does not sound so good, because my provider will not keep PHP 7.4, this was stated very clearly. Okay so at the end, this means a lot of work to migrate to another cloud…