Owncloud Upgrade 10.8 to 10.9 Error 403 marketplace.owncloud.com

Hello All

I tried to upgrade the owncloud to the latest version manual mode:

Repair warning: No marketplace connection: Client error response [url] hxxps://marketplace.owncloud.com/api/v1/platform/10.9.0/apps.json [status code] 403 [reason phrase] Forbidden

I get on Ubuntu 20.04 LTS this:

2021-12-26T21:07:14+01:00 Repair warning: No marketplace connection: Client error response [url] https://marketplace.owncloud.com/api/v1/platform/10.9.0/apps.json [status code] 403 [reason phrase] Forbidden
2021-12-26T21:07:14+01:00 Repair warning: You have incompatible or missing apps enabled that could not be found or updated via the marketplace.
2021-12-26T21:07:14+01:00 Repair warning: Please install or update the following apps manually or disable them with:
occ app:disable activity
occ app:disable announcementcenter
occ app:disable brute_force_protection
occ app:disable checksum
occ app:disable diagnostics
occ app:disable duo
occ app:disable extract
occ app:disable files_clipboard
occ app:disable files_external_dropbox
occ app:disable guests
occ app:disable impersonate
occ app:disable metadata
occ app:disable nextbackup
occ app:disable password_policy
occ app:disable phonetrack
occ app:disable templateeditor
occ app:disable twofactor_backup_codes
occ app:disable twofactor_totp
occ app:disable wallpaper
2021-12-26T21:07:14+01:00 Repair warning: For manually updating, see https://doc.owncloud.com/server/10.9/go.php?to=admin-marketplace-apps

Curl is working…

Does someone know what happens?

Best, Fab

I was able to upgrade but

still persists: REPAIR warning: No marketplace connection: Client error respone [URL] hxxps://marketplace.owncloud.com/api/v1/platform/10.9.0/apps.json [status code] 403 [reason phrase] Forbidden

?! no idea… With 10.8 i have no issues…

I solved the first issue with copying back the old apps to the new apps folder.

But error 403 still persists.

Restored old configuration.

An issue?

Best, Fab

PS: wget https://marketplace.owncloud.com/api/v1/platform/10.9.0/apps.json is working and i am able to download… So no connection issue…

People are discussing this issue on GitHub:

Current workaround is to create a Markplace API key and apply it in your ownCloud until a fix is in place.

1 Like

I found a similar issue on my side after upgrading to 10.9.
To solve I create an account on the marketplace, https://marketplace.owncloud.com/ and I copy the API key to my marketplace configurations.

@Bruno_Cantante
Can you elaborate how you did it?
I have the same issue and rootcerts.crt removal didn’t work.

Another workaround has been found:

delete from oc_appconfig where appid = 'market' and configkey = 'key';

A configvalue of NULL is now being interpreted as string, and that string is being used to connect to the marketplace, but marketplace rejects it as being incorrect. So if you remove this row from the database with the above command, it should start working as expected again.

2 Likes

Hello Everybody! Thank you so much for the fast feedback. I will register for an api… :wink:

Thank you @ll!!!

Best, Fab

We are preparing a new release for the market app, which would remove the workaround.

I don’t think you have read this thread at all. Here are the solutions:


Workaround #1


Workaround #2


Workaround #3

Install pre release (not fully tested yet)

Market app is finally released on Marketplace

1 Like

Hi,

  1. Go to the Marketplace
  2. Copy the API Key;
  3. Open your Owncloud;
  4. Go to the market;
  5. Paste the API Key on Configurations > Edit API Key,

Thanks @Bruno_Cantante !
It worked fine