ownCloud Virtual File System - Discussion

Hey @gpapaiko, thanks for reporting! About…

We found out a potential bug in 2.5alpha1 that might be causing this scheduling behavior you’re seeing:

Stay tuned for the next 2.5 beta or try out one of our latest daily builds from https://download.owncloud.com/desktop/daily/

Hope this helps! Best!

1 Like

@gpapaiko quick correction; the issue I referenced was introduced later than alpha1; so it should not be present with the client you used to report this.

Can you capture some logs (https://doc.owncloud.org/desktop/latest/troubleshooting.html#log-files) and send them on our way for further troubleshooting?

Thanks again!

@alfageme, will do I’ll reset my VM and test it again and send you the client log files.
Thanks.

1 Like

Any news from this side? Is the issue tracked down? :slight_smile:

Hi Sorry forgot all about it.
Had been busy with meetings and all.
Just check the VM and owncloud still had not created any virtual folders.
It has now been running for over a week,
The client log file is only 16Kb.

Client has Still cycling through “Checking for changes in remote…”
The progress bar has not move at all.just keeps cycling through the folders.

Extract, of log file.
It just keep repeating the “(last step: xxxxx…”, not sure if this is of any help…

timestamp | duration | file | instruction | dir | modtime | etag | size | fileId | status | errorString | http result code | other size | other modtime | X-Request-ID
#=#=#=# Syncrun started 2018-06-18T10:08:44Z
#=#=#=# Syncrun finished 2018-06-18T10:10:23Z (last step: 98889 msec, total: 98889 msec)
#=#=#=# Syncrun started 2018-06-18T10:10:38Z
#=#=#=# Syncrun started 2018-06-18T10:13:50Z
#=#=#=# Syncrun finished 2018-06-18T11:13:49Z (last step: 3599882 msec, total: 3599882 msec)
#=#=#=# Syncrun started 2018-06-18T11:14:49Z
#=#=#=# Syncrun finished 2018-06-18T12:13:51Z (last step: 3541803 msec, total: 3541803 msec)
#=#=#=# Syncrun started 2018-06-18T12:14:51Z
#=#=#=# Syncrun finished 2018-06-18T12:23:58Z (last step: 597622 msec, total: 597622 msec)
#=#=#=# Syncrun started 2018-06-18T12:24:37Z
#=#=#=# Syncrun finished 2018-06-18T12:57:36Z (last step: 1978983 msec, total: 1978983 msec)
#=#=#=# Syncrun started 2018-06-18T12:58:35Z
#=#=#=# Syncrun finished 2018-06-18T13:13:51Z (last step: 915226 msec, total: 915226 msec)
#=#=#=# Syncrun started 2018-06-18T13:14:39Z

If you have anything you want me to try let me know.

But what I have notices, that on existing pc that are using client 2.4.1, it is now also taking longer to sync the files. Also just noticed that my main PC had automatically upgraded to 2.4.1, and has not synced for a day or so, hence not sure if this related.

One PC I actually had to remove the client, and install 2.3.4 for it to work, and stop it from upgrading.
This seems to be a side-effect, so not sure if this has done anything to the owncloud server.

Sorry forgot to add the log files:
URl to download the flog files

2.5.0 beta1 is out :slight_smile:

2 Likes

Hello everyone, we’re at 2.5.0 beta2 now. Please give it a try @Andrew_Clemence, @virgule, @gpapaiko etc. :slight_smile:

(The 2.5.0 release also contains a ton of other improvements)

2 Likes

This is a great feature. I really love the idea of having the whole structure in the finder.
I installed 2.5.0 client on Mac, enabled experimental features and re-added my connection checking the VPS option. However, the ownCloud folder just stays completely empty and I don’t see any sync activity going on. The top bar icon shows the check mark. What do I do wrong? Really want to test this feature.
I’m on MacOS Mojave.

Can you try again with this package?

https://download.owncloud.com/desktop/stable/ownCloud-2.5.1.10818.pkg

1 Like

Virtual File System only worked when I had default owncloud share. All my files are on external storage (a WC mycloud NAS, OWC runs on a pi3b+). When i ask to download the files using the client right click action nothing happens.

I’m using 2.5.4 (build 11456) on mojave 10.14.4 (18E226).

When I’m using full file sync it does work

1 Like

@Tiago_Santos could you check with the 2.6.0-alpha1?

In case the problem isn’t fixed, please open a new issue and provide the necessary information:
https://github.com/owncloud/client/issues

1 Like

It is better, but still it doesn’t gives the usage for real life context. If you’re patient enought to open the browser and download the file you need it works, else you must do real file sync and it doesn’t work so awesome…

Other issue (good and bad) when I dele files it doesn’t propagate to any external storage sync I’ve.

2.6.0 beta1 has been released which contains many improvements on the VFS side, both for Windows and macOS/Linux platforms.

1 Like

Virtual file feature taking hours to make first sync, in my case it took about 3 hours to sync 46GB of data.
My understanding is, currently sync client checking all files one-by-one on server and generating a database file on local computer and making empty file for every file on server.
My suggestion is to generate the user database file on server and send it across o sync client and then create the local empty files, this way virtual file sync will be instant.
2nd option
Initially generate the structure of root directory make is available to for user to see and keep generating the structure of sub-directories as the user is navigating the directory tree this way user will feel that all the data is already there and, in the background client can keep syncing the full file structure.

1 Like

@munim Thank you very much for your valuable feedback. What exact version of the client did you try? What is the exact version of your operating system? We’ll release a RC1 the next few days that should behave much better.

Thank you for noticing and responding my post.
I tried 2.5.4 and 2.6.0beta1 on windows 10 x64 built 1903 and both have similar behaviour.

@munim What steps did you perform? New initial sync with no files local and a big remote account? Or did you added the files to an existing sync folder connection? What number of files did you test?

Please try 2.6.0 rc1 :slight_smile: it might behave better, especially on Windows 10.
Download links are at https://github.com/owncloud/client/issues/7063#issuecomment-527873086

Yes it was initial sync around 44k files and total data size was 46GB.

Thank you i will try.