PHP FPM Nginx unable to upload more than 2 GB of file

help

#1

I am using a 64 BIT CENT OS with php 5.6 and with nginx/php fpm.

I am running a owncloud instance in the VPS and everything is running smoothly, except to the fact that any file which is more than 2 GB in size is not getting uploaded and gets a gateway error, I tweaked all the settings as said in

https://github.com/owncloud/documentation/wiki/Uploading-files-up-to-16GB

All the values are set, still whenever php-fpm writes the file to the temp directory, it stops exactly at 2 GB, sometimes 2.1 or 2.2 but not after that, it is not time out issue as sometimes if i upload 7 GB of file, it uploads for hours and progress bar goes without any issue till 100 % and then stops, checking in tmp folder i could see,

cd /var/www/owncloud/temp/

[root@files temp]# ll -ah

-rw------- 1 nginx nginx 2.2G Feb 9 17:46 phpyHKRQD

I am super confused here, as why php would stop at 2 GB in a 64 BIT environment.


#2

There is also a documentation at [1] (Especially note the fastcgi_request_buffering off; there) as well as a FAQ at [2]. If you need further support with webserver and PHP issues you might also get in touch with the nginx support community [3]. They might have more knowledge how to debug such webserver / PHP issues.

[1]

https://doc.owncloud.org/server/latest/admin_manual/configuration_files/big_file_upload_configuration.html

[2]

[3]

https://nginx.org/en/support.html


Problem on downloading large files
#3

Yup, I missed the request buffering off setting which resolved the issue,Thanks.