Problem on downloading large files

known_bug
help
9.1.x

#1

Hello.

I've got a problem on downloading larger files.
My OS: Ubuntu 16.04.1 LTS
OwnCloud: 9.1.3
PHP: 7.0.13
mariadb: 15.1
nginx: 1.11.8

Uploading large files is no problem. When I download a large file, the download stops at 1GB.

Here my nginx settings:
keepalive_timeout 6000;

         proxy_connect_timeout 6000;
         proxy_send_timeout 6000;
         proxy_read_timeout 6000;
         send_timeout 6000;

        client_max_body_size 10G;
        fastcgi_buffers 64 4K;
        fastcgi_read_timeout 6000;
        fastcgi_send_timeout 6000;
        fastcgi_connect_timeout 6000;

         upload_max_filesize = 4G
         post_max_size = 4G
         max_execution_time = 3600

The settings in the /fpm/php.ini:
max_execution_time = 1800
max_input_time = 3600
memory_limit = 2G
post_max_size = 4G
upload_max_filesize = 4G
default_socket_timeout = 600

I'm searching for a solution for some days, a working solution I don't found :(.

Any ideas?

Thanks a lot for your answers!

Regards

Dirk


#2

Do you get any error message during the download?


#3

Hello Sarah.
No, on the browser window. In Firefox I've got "Abborted" , in Chrome Network error.
For analysing the network traffic I used also Wireshark. The last packet is smaller than the other packets.
My server exits since two months. I started with owncloud 9.1.1. The version makes no difference.
Installing new patches to php, mariadb and ubuntu makes also no differences.

Regards

Dirk


#4

Have you got special firewall settings with limits for file downloads? Do you host internal or external?
Does the server (owncloud.log) is saying something about the exit, too?


#5

Hello Sarah.

Here are the last lines of my owncloud.log:
{"reqId":"ALJaWnm1cEQJ0mSuSbIK","remoteAddr":"192.xxx.xxx.xxx","app":"PHP","message":"Uncaught Error: Access to undeclared static property: OC\Files\Filesystem::$normalizedPathCache in \/var\/www\/owncloud\/lib\/private\/Files\/Filesystem.php:793\nStack trace:\n#0 \/var\/www\/owncloud\/lib\/private\/Files\/View.php(2039): OC\Files\Filesystem::normalizePath('\/25769CA7-D52E-...')\n#1 \/var\/www\/owncloud\/lib\/private\/Files\/View.php(1151): OC\Files\View->unlockFile('\/ISO-Files\/ubun...', 1)\n#2 [internal function]: OC\Files\View->OC\Files\{closure}()\n#3 \/var\/www\/owncloud\/3rdparty\/icewind\/streams\/src\/CallbackWrapper.php(109): call_user_func(Object(Closure))\n#4 [internal function]: Icewind\Streams\CallbackWrapper->stream_close()\n#5 {main}\n thrown at \/var\/www\/owncloud\/lib\/private\/Files\/Filesystem.php#793","level":3,"time":"2017-02-02T12:38:29+00:00","method":"GET","url":"\/owncloud\/ocs\/v2.php\/apps\/notifications\/api\/v1\/notifications?format=json","user":"25769CA7-D52E-41B9-B998-17A29BA73B51"}
{"reqId":"c0rykupCsaSMzK3TOvkI","remoteAddr":"192.xxx.xxx.xxx","app":"PHP","message":"DateTime::__construct(): Failed to parse time string ("2028b2816a0a38020028fc773b3eb1e3") at position 0 ("): Unexpected character at \/var\/www\/owncloud\/3rdparty\/sabre\/dav\/lib\/DAV\/CorePlugin.php#131","level":3,"time":"2017-02-02T12:39:46+00:00","method":"GET","url":"\/owncloud\/remote.php\/webdav\/ISO-Files\/ubuntu-15.04-desktop-i386.iso?downloadStartSecret=fiwt5nh40uqss7vmka9qnnrk9","user":"25769CA7-D52E-41B9-B998-17A29BA73B51"}
{"reqId":"G1zj1gaQaiwruipjwwlT","remoteAddr":"192.xxx.xxx.xxx","app":"PHP","message":"Uncaught Error: Access to undeclared static property: OC\Files\Filesystem::$normalizedPathCache in \/var\/www\/owncloud\/lib\/private\/Files\/Filesystem.php:793\nStack trace:\n#0 \/var\/www\/owncloud\/lib\/private\/Files\/View.php(2039): OC\Files\Filesystem::normalizePath('\/25769CA7-D52E-...')\n#1 \/var\/www\/owncloud\/lib\/private\/Files\/View.php(1151): OC\Files\View->unlockFile('\/ISO-Files\/ubun...', 1)\n#2 [internal function]: OC\Files\View->OC\Files\{closure}()\n#3 \/var\/www\/owncloud\/3rdparty\/icewind\/streams\/src\/CallbackWrapper.php(109): call_user_func(Object(Closure))\n#4 [internal function]: Icewind\Streams\CallbackWrapper->stream_close()\n#5 {main}\n thrown at \/var\/www\/owncloud\/lib\/private\/Files\/Filesystem.php#793","level":3,"time":"2017-02-03T09:36:53+00:00","method":"PROPFIND","url":"\/owncloud\/remote.php\/webdav\/","user":"25769CA7-D52E-41B9-B998-17A29BA73B51"}

Fot testing I use an iso-file.

Regards

Dirk


#6

The log file is looking like in the bug https://github.com/owncloud/core/issues/22370 and that was fixed 10 days ago.


#7

Hello Sarah.

The problem still exists :(. For the moment the machine is on the latest updates (includes owncloud is now on 9.1.4)
The owncloud after update has an integrity problem.

i.e.:
[core/doc/admin/enterprise_installation/license_keys_installation.html] => Array
(
[expected] =>
[current] => 34565339c9688624384e671e4cb4e13a91afee2964a2fdcfd168246cf0461cc4d19df0f79fb14a015194dcee2e56678347da399f6e435c3b679b5cdc20829376

Rescanning don't solve it.I testet with browser and shell. Here I'searching for a solution...

Regards

Dirk


#8

Are you a Enterprise customer?
The license will be configured in config/config.php.


#9

Good morning Sarah.

No, we are no Owncloud Customer.

Regards

Dirk


#10

Backup the config.php. You can see, that nothing was expected. You need the license key as a enterprise customer. Look after "license-key" and remove the key there.


#11

For the download problem: Try this solution https://central.owncloud.org/t/php-fpm-nginx-unable-to-upload-more-than-2-gb-of-file/5711/2

And look after the max_execution_time.


#12

Hello Sarah.

I'm sorry for my late answer :(.

This are my settings here:
fastcgi_param PHP_VALUE "open_basedir=/var/www:/tmp/:/var/owncloud-data:/dev/urandom
upload_max_filesize = 4G;
post_max_size = 4G;
max_execution_time = 3600";

It don't changes anything. Last week I installed the latest updates. No changes here.
For testeing I changes upload_max_filesize and post_max_size from 4G to 4096M. Also no changes here.

Regards from Hannover

Dirk


#13

The issue should be fixed in ownCloud 9.1.4.
Try an update, please.
If it doesn't work, add your behaviour in https://github.com/owncloud/core/issues/22370 .


#14

Hello Sarah.

I'm sorry for my (too) late answer. With an installation of version 9.1.5 via shell the problem don't exits anymore.

Regards

Dirk