Remember Me Option On Login Missing

So in OwnCloud users don’t have the option to stay logged in. That is a really annoying thing and keeps users (myself included) from using it more often.
The really dissapointing thing about it is, that the doc still lists a config parameter that was used for this feature in 9.x. I cannot figgure out why they removed it in 10.x (at least it appears that that was the case)

Has anyone an idea why they removed it or how to get it back (possibly via app or smth.)

Any help appreciated

It isn’t removed, but kind of hidden. It depends on apps not explicitly rejecting the option, so it’s likely an app the one that is telling ownCloud not to show the “remember me” option.

As far as I know, the “files_external” app is one of the apps that tells ownCloud to hide that option. If I remember correctly, there were problems if the “remember me” option was checked and the user accessed to external storages. It might depend on specific setups or with specific configurations.

If you aren’t using external storages, you can disable that app (at least in 10.10) and that should bring up the option. I’m not sure how well it will work since I’m not using it.
If you’re using external storages, I don’t think there is anything to do because, as said, it could cause issues.

1 Like

That is very interesting…
Sadly I don’t have the app installed, so it can’t be that. I don’t use any external storage…

Any other ideas on what it could be?

You can have a look at the info.xml files of all apps looking for core/info.xml at 774453ede496223ef58a0ec61b67478f3523ea41 · owncloud/core · GitHub , but you mustn’t change the file. At most, you can disable the target app if disabling the app won’t cause issues.

The “encryption” app also has the same flag, but I don’t think you can disable this app once it’s enabled.

I looked again, I had External Storage enabled, but it doesn’t show in “Apps” tab of the admin section…
I disabled it, but the checkbox didn’t appear. I have to go through every app an look if its info.xml has the option turned on. But at least its a starting point, thank you :slight_smile:

Ok, so I searched through my owncloud /apps directory. I found only two apps that use this declaration:

  1. files_external as mentioned
  2. encryption

both are deactivated and not used. Since these are apps that ship with owncloud (I think) I cannot uninstall them. So if these two apps should be the problem, what should I do?

And if I check

  • on the storage tab it says External Storage deactivated by Administrator
  • on the encryption tab it says Activate server encryption
(actually it says something different in german, so sorry if that is not a quite correct translation)

Could you double-check? You couldn’t disable the files_external app until recently (I think OC 10.10 version), so maybe the app is still enabled. If you still have the storage section in the settings page, the app wasn’t disabled.

You can also check with the occ app:list command.

If you’re using an earlier version, you’ll have to upgrade to be able to disable the files_external app.

Yeah you’re right, its still enabled. The thing is that i am on oc 10.9.1 and my updater says that it is the latest version, so oc 10.10 is not stable yet, right?

I think it’s considered as stable, but

Ok, well then I’m gonna wait for Owncloud to give me the option to update and then we’ll see…

So I maually upgraded Owncloud now, because the automatic updater wouldn’t work. I can deactivate the files_external app now and when I do it I get the Remember Me Option, so thank you @jvillafanez

Ok, so the checkbox is there, but I don’t think that it is working. The cookies I have after logging in with the checkboxed checked, the cookies look like that:
grafik
The SessionPassphrase is like 20 minutes in the future. That is the default for session_lifetime. My setting for remember_login_cookie_lifetime is the default: 15 days.

Any ideas?

Taking into account that the feature was hidden for a long time, it might be broken or there might be additional conditions to make it work.

I’ve opened Remember me option doesn't work · Issue #40170 · owncloud/core · GitHub to keep track of the issue.

3 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.