[Resolved] Again the max upload size above 2MB


#1

Hello
I know there is plenti of tuto explaining how to do it but I have try them…

My conf : Ubuntu 18.04, Apache2, Owncloud 10.0.10
I try to change the 2MB limit in :

  • all the php.ini I found with “locate”
  • the .usrer.ini
    -the .htacess

But I still have a limitation to 2 MB!

No error message in the log file. No yellow warning on the page to say it is to big (the % bare graph goes from 0 to 100 but file did not apear)
No “PUT” request with the filename in the access log file (as it does appear with small file)

Any idea ?

Thanks


Problem with syncing (INSTRUCTION_SYNC) files that are bigger than 10M AND contain special characters
#2

Some more information :
The modification of the php.ini works as <?php phpinfo()?> indicate that post_max_size and upload_max_size are both to “16G”


#3

Hey,

maybe you could ask the support of your hoster to ask if they have some additional configuration in place which prevents your web server or PHP to allow ownCloud uploading larger files?


#4

Thanks for reply but there is no hoster il the loop.
Owncloud is on my server.


#5

Hey,

ok so then i think the “Hosting area” chosen to post this topic is a little bit misplaced :slightly_smiling_face:. From what i know this should be used if you’re not running your own server but using an ownCloud installation on a hosting provider.

If i’m creating a new thread in this category i’m getting the template below presented. Maybe you could fill out the information asked within it so people are better able to help you?

I think especially the “logfiles” part could be useful.

<!--
Thanks for reporting issues back to ownCloud! This is the issue tracker of ownCloud, if you have any support question please check out https://owncloud.org/support

This is the bug tracker for the Server component. Find other components at https://github.com/owncloud/core/blob/master/.github/CONTRIBUTING.md#guidelines

For reporting potential security issues please see https://owncloud.org/security/

To make it possible for us to help you please fill out below information carefully.

Before reporting any issues please make sure that you're using the latest available version for your major branch (e.g. 9.0.x), see https://owncloud.org/changelog/
--> 
### Steps to reproduce
1.
2.
3.

### Expected behaviour
Tell us what should happen

### Actual behaviour
Tell us what happens instead

### Server configuration
**Operating system**:

**Web server:**

**Database:**

**PHP version:**

**ownCloud version:** (see ownCloud admin page)

**Updated from an older ownCloud or fresh install:**

**Where did you install ownCloud from:**

**Signing status (ownCloud 9.0 and above):**

```
Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.
```


**The content of config/config.php:**

```
Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.
```

**List of activated apps:**

```
If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.
```

**Are you using external storage, if yes which one:** local/smb/sftp/...

**Are you using encryption:** yes/no

**Are you using an external user-backend, if yes which one:** LDAP/ActiveDirectory/Webdav/...

#### LDAP configuration (delete this part if not used)

```
With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';


Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.
```

### Client configuration
**Browser:**

**Operating system:**

### Logs
#### Web server error log
```
Insert your webserver log here
```

#### ownCloud log (data/owncloud.log)
```
Insert your ownCloud log here
```

#### Browser log
```
Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log 
c) ...
```

#6

Sorry my mistake
I have removed the Hosted tag.

Here below the information :

### Steps to reproduce
1.Upload a file larger than 2Mb
2.The % bare apear but a the end the file is not in owncloud
3.No yellow warning in the upper part

### Expected behaviour
The file should be present

### Actual behaviour
The file if bigger than 2MB is not present

### Server configuration
**Operating system**:
Ubuntu 18.04
**Web server:**
Apache 2
**Database:**
10.1.34-MariaDB-0ubuntu0.18.04.1
**PHP version:**
php 7.2
**ownCloud version:** (see ownCloud admin page)
10.0.10.4
**Updated from an older ownCloud or fresh install:**
fresh install
**Where did you install ownCloud from:**
wget
**Signing status (ownCloud 9.0 and above):**

No errors have been found.


List of activated apps:

Enabled:
  - comments: 0.3.0
  - configreport: 0.1.1
  - dav: 0.4.0
  - federatedfilesharing: 0.3.1
  - federation: 0.1.0
  - files: 1.5.1
  - files_external: 0.7.1
  - files_sharing: 0.11.0
  - files_trashbin: 0.9.1
  - files_versions: 1.3.0
  - files_videoplayer: 0.9.8
  - firstrunwizard: 1.1
  - market: 0.2.5
  - notifications: 0.3.5
  - provisioning_api: 0.5.0
  - systemtags: 0.3.0
  - updatenotification: 0.2.1
Disabled:
  - encryption
  - external
  - user_external

**Are you using external storage, if yes which one:** local/smb/sftp/...
only nfs
**Are you using encryption:** yes/no
no
**Are you using an external user-backend, if yes which one:** LDAP/ActiveDirectory/Webdav/...
no


### Client configuration
**Browser:**
firefox
**Operating system:**
ubuntu 18.04
### Logs
#### Web server error log

no specific log


#### ownCloud log (data/owncloud.log)

no error log


#7

Some new information
My owncloud server (with apache) is behind a front web server in nginx.
This nginx server apply a proxy pass to the apache.

And the problem seem’s link with this configuration.
When I connect directly to the apache server with “IP of owncloud”/owncloud the file larger than 2MB can be upload.
When I connect to owncloud.mydomain.com (which send to the front web server in nginx) the upload over 2MB does not work.
Any new idea to see where the upload is stucks…

Thanks


#8

It works !!!
I just have to add :
client_max_body_size 16G;

in the server configuration (owncloud.conf file in the site-enable of nginx)


#9

Hey,

nice that you got this to work. It seems this setting is even documented here:

https://doc.owncloud.org/server/administration_manual/configuration/files/big_file_upload_configuration.html


#10

Hello,

In which file should I add client_max_body_size 16G; ?


#11

In the “/etc/nginx/sites-available/owncloud.conf”
in the server configuration :
server {

client_max_body_size 16G;

}


Iphone uload size limit