Slow Upload Speeds

help

#1

When uploading a single 680 MB file via the web interface or the Windows desktop sync client I get transfer speeds in the 5-8 Mbps range. This is over a 100 Mbps wired LAN; sftp uploads to the server run at ~99 Mbps. Using top on the server, cpu utilization is under 10% and memory usage is under 50%. Using iotop, I see apache doing about 1000-1300 KB/s of IO, and occasionally mysql doing about 3 MB/s for brief periods (around a second ever 20 or 30 seconds). CPU and memory usage is also low on the client during the upload.

I was hoping for speeds in the 30-50 Mbps range. Any ideas to try to improve the upload speed?

I've got a pretty simple configuration: everything owncloud-related is running on a single machine, there are no proxies, no server-side encryption, no external storage, no external authentication/users. It's running on bare metal, not a VM. The one somewhat exotic thing is the server is using btrfs, per the recommendation in the documentation. I also changed the upload limit to 10 GB.

I've tried with and without APCu data cache (doesn't seem to make a difference). I haven't tried a distributed cache.

I don't see any errors during the upload in the logs, and the settings/integrity/failed page shows "No errors have been found."

I've run through the problem module list (https://central.owncloud.org/t/known-problems-with-php-webserver-modules-or-configs/835). The only potential issues were:

The Apache authentication module. I do have the "auth_basic_module" loaded. However, I do not have an "AuthType" entry in my vhost section or my .htaccess file.

mod_deflate. I do have "deflate_module" loaded, but reading the issues related to that made me think this was either no longer an issue, or that I would be getting error messages in the logs. Apache also gave me a big scary warning when I tried to disable it, so I thought I would wait on advice before trying to disable. I can disable this if there's reason to believe it may be an issue.

Server configuration
Operating system: Ubuntu 16.04 LTS
Web server: Apache 2.4.18
Database: MySql 14.14 Distrib 5.7.15
PHP version: PHP 7.0.8-0ubuntu0.16.04.3
ownCloud version: 9.1.1 (stable), fresh install from Ubuntu package


#2

Closing as a duplicate of the following thread (and potentially a few others):

From user side there is nothing really what can be done here except the default operating system, webserver and database tuning which are not oC specific.


#3