Stuck in Maintainance Mode


#1

I have just upgarded to the latest version of OC, and my instance has been stuck in maintainance mode for the past couple of hours.

Is there anyway to manually set it back to on-line?

Is there any reason why it might have got stuck?


Upgrade to owncloud-10.0.9 fails
#2

You’re not alone! :wink:


#3

This is proving to be deeply frustrating. :frowning:
Does anyone have any solutions?
I’m not sure if by simply editing my configuration file I am going to solve the issue or cause more problems, so would appreciate someone elses view on the matter. :slight_smile:


#4

Not yet, unless restoring from backup.


#5

I’d rather go forwards than backwards. :wink:


#6

If I modify the config.php file to maintainance mode = “false” I get the following:


If I then remodify the config.php file back to “true”, I get:
2018-08-03%2022_09_01-ownCloud%20and%202%20more%20pages%20%E2%80%8E-%20Microsoft%20Edge
So ok, does anyone know what has gone wrong?


#7

So here’s what I did.
After setting the “maintenance mode back to true”, I reinstalled the missing apps.
Then, I went back and reset the “maintenance mode back to false”. Owncloud asked me to resyncronise the database which I did, and now it works again.


#8

Worked on both my OwnCloud installations. :slight_smile:


#9

Hi Paul, I have the same issue that my update got stuck in maintenance mode. Now I need obviously to update or disable some apps. How do I do this exactly or how did you do your upgrade of the apps exactly?

Many thanks in advance!
Ralph


#10

In my case the missing Application was the Oauth2 app. I had a backup copy of the application saved locally on my pc and was able to reinstall it in the app folder on the server. Once this was done I re-resynchronised the database and all worked perfectly.


#11

I am having some problems with my OwnCloud installation.
It is stuck in maintenance mode and refuses to release itself despite trying to disable the apps.
Is there a way to run a repair script that might free the application up, or do I have to reinstall the whole package?


#12

You can disable the videoplayer directly in the DB, using phpMyAdmin or similar. Then retry your upgrade.


#13

Hey,

i’m not sure if its a good idea to upgrade to a “prealpha” version when not having the knowledge how to debug and solve issues on your own. As a user i would at least wait for a “beta” or “release candidate” version instead.


#14

The problem occurred before I tried this, thus I tried to reinstall using this version, which also didn’t work.
I realize not the most intelligent way to go about this, but this is a test site so figured what the heck.

For what it’s worth, the same error came up on my production site, but I fixed that without problems.


#15

Hey,

which might confirm that a prealpha isn’t really ready to be used as an user. :slightly_smiling_face: