Synchronisation vom Desktop Client funktioniert nicht mehr


#1

Bitte die folgenden Infos bereit stellen. Bevor ein Thread erstellt wird beachte die angepinnten "Known issues" threads und stelle sicher dass Du die letzte verfügbare Version Deines oC releases verwendest: https://owncloud.org/changelog/

Schritte zum Reproduzieren
1. Verbindung zum Server herstellen -> Kein Erfolg
2. Neuinstallation vom Client
3. Verbindung zum Server herstellen -> Kein Erfolg

Erwartetes Verhalten
Verbindung zum Server funktioniert.

Aktuelles Verhalten
Ich erhalte die Meldung "Zugang vom Server nicht erlaubt".

Server-Konfiguration
Betriebssystem: CentOS 7.3
Webserver-Typ: Apache 2.4
Datenbank-Typ: MariaDB 10
PHP-Version: 7.0
ownCloud-Version: 9.1.3
Von einer älteren ownCloud-Version aktualisiert oder neu installiert?: Beides
Sonderkonfigurationen (external storage, external authentication, reverse proxy, server-side-encryption): -

ownCloud log (data/owncloud.log)

Bitte füge mögliche Fehler in den folgenden Code-Block, siehe https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 für mehr info.

Keine Einträge bzgl. ownCloud.

Integrity status für oC9+

No errors have been found.

Zusätzliche Angaben
Wir haben vorher einen CentOS 7.2 Server mit PLESK betrieben und sind nun auf einen neuen Server mit CentOS 7.3 und cPanel / WHM umgezogen. Der Umzug wurde vom cPanel-Supportteam durchgeführt und sah auch erst vielversprechend aus. Seit dort an, funktioniert die App-Verbindung aber nicht mehr.

Darauf hin haben wir unsere ownCloud Installation gelöscht und eine frische installiert, damit wir den Umzug ansich ausschließen können. Aber auch hier ist keine Verbindung mehr möglich, auch eine Neuinstallation des Windows-Clients hat nichts gebracht.

Angaben zu cPanel / WHM: Apache 2.4 (EasyApache 4) mit MariaDB10.

Ich hoffe ihr könnt mir helfen.


#2

Höchst wahrscheinlich ist da noch die Webserver konfiguration kaputt. Hier findest Du ggf. weiterführende Infos zum Thema und mögliche Lösungen:


#3

Dank dir.

Es waren in der Tat die fehlenden Module "mod_dav" und "mod_dav_fs" des Apaches.


#4

Die beiden Module werden aber definitiv nicht benötigt (oC bringt eine eigene WebDAV implementation mit) und sollten nicht aktiviert werden.

Höchst wahrscheinlich hat das aktivieren der Module jedoch auch die benötigten WebDAV Methoden im Webserver "unblocked".

Deaktiviere also am besten wieder beide Module, damit es keine Konflikte mit der oC WebDAV implementierung kommt und schau Dir mal posts wie z.B. https://forum.owncloud.org/viewtopic.php?f=3&t=2071 an