Syncing Owncloud calendar in MAC OSX El Capitan

calendar
9.1.x

#1

Hi,

I'm trying to sync one of my friends' calendars in Mac OSX El Capitan. When I try to create a calDAV account and enter the required information, I get "unable to verify account name or password." error message. Here is the info I provide:

Account name: manual
User Name: joe
Password: password
Server Address: https://example.com/owncloud/remote.php/principals/users/joe

Is the server address correct? Does it work with https? Because there is no http.


Can't use OC 10 Calendar with Mac OSX 10.12
#2

Did you set the redirect for https://example.com/.well-known/carddav?
https://doc.owncloud.org/server/9.0/admin_manual/issues/general_troubleshooting.html#troubleshooting-contacts-calendar


#3

Hi,

you get the correct URL in the calendar app at the bottom left near the calendar name


#4

So, I'm running Apache and the Owncloud instance is installed in /var/www/owncloud. I should create .well-known/carddav and .well-known/caldav in /var/www/owncloud and then add the following two lines to /var/www/owncloud/.htaccess :
Redirect 301 /.well-known/carddav /owncloud/remote.php/dav
Redirect 301 /.well-known/caldav /owncloud/remote.php/dav
?
But what are carddav and caldav? Are they files that should be created in .well-known? What about their permission?


#5

@RealRancor: Yes, I got the server address exactly from their.


#6

Hi,

please read the link of tflidd above again. You shouldn't add any files and folders but add those things into your main webserver vhost (/var/www/owncloud/.htaccess won't work).

This is due to a long running bug which apple doesn't fix since a longer time:


#7

Thanks RealRancor for the help! So I added the folowing lines to the Apache's vhost just after the DocumentRoot which is /var/www/owncloud:
Redirect 301 /.well-known/carddav /remote.php/dav
Redirect 301 /.well-known/caldav /remote.php/dav

and I restarted the Apache server. In the client, the server address I use is: https://example.com/owncloud. I've also tried to use the complete address I get from the place you suggested but I'm still getting the same error message. Am I still doing something wrong?


#8

Which is wrong in this case. You need to enter "https://example.com" as the server address.


#9

Hi,

if you have trouble with the redirect, as I had, you could try the following:

What works for me now on OS X 10.11 (owncloud server in subdirectory, .well-known redirects removed):
Add a CardDAV or CalDAV account through "Internet Accounts" in "System Preferences".
Account Type: Advanced
User Name: myusername
Password: userpassword
Server Address: www.example.com
Server Path: /owncloud/remote.php/carddav/principals/myusername/
Port: 443
Use SSL: X
Replace carddav with caldav in the path when adding a caldav account.
If you don't use https, uncheck SSL and set the port to 80.

Hope this helps :slight_smile:


#10

@RealRancor: I get the same error message even when I enter https://example.com

@BeelVanBaer : man, it works :D!! Thanks a lot.

Thanks a lot you all for the help.


#11

Probably the still unfixed bug of Apple with the Account Wizard? Really wonder why it takes that long to fix this long running issues from their side.


#12

Not a priority maybe? Really no idea.


#13

@RealRancor

Thank you very much, this worked for my Calendar in macOS but it did worked for my contacts , and still having problem with iOS, I would really appreciate if you help me with those too.