"This operation is forbidden" after fresh install

9.1.x
help

#1

Hello,

I have a problem after installing ownCloud on a fresh CentOS 6.8 server.
More exactly, after installing it via Web Installer, on the Files page I got the "The operation is forbidden" error and I can not see any files and in Admin / Logs I got those two MySQL errors as you see in screenshot:

I know about the Warnings, I know how to fix them, but even with them fixed still nothing.

In the app, after entering credentials, I got the "It is not possible to connect to the server at this time" error.

I also use Let's Encrypt manager for this subdomain.

After many searches, I guess the only issue is an error on Apache vhost configuration, but I can't figure out what is exactly..

OS: Centos 6.8
Apache: 2.2.27
PHP version: 7.0.10 (also tried on 5.4.45)
MySQL version: 5.1.73
Control panel: Centos Web Panel PRO 0.9.8.145

Contents of /usr/local/apache/conf.d/vhosts.conf:

# vhost_start cloud.vasile.TLD
<VirtualHost 100.100.100.100:8181>
ServerName cloud.vasile.TLD
ServerAlias www.cloud.vasile.TLD
ServerAdmin mail@mail
DocumentRoot "/home/vasile/public_html/cloud/"
ScriptAlias /cgi-bin/ /home/vasile/public_html/cloud/cgi-bin/
# 
# Custom settings are loaded below this line (if any exist)
# Include "/usr/local/apache/conf/userdata/vasile/cloud.vasile.TLD/*.conf

<IfModule mod_suexec.c>
        SuexecUserGroup vasile vasile
</IfModule>

<IfModule mod_suphp.c>
        suPHP_UserGroup vasile vasile
</IfModule>

<Directory "/home/vasile/public_html/cloud/">
        AllowOverride All
</Directory>

</VirtualHost>
# vhost_end cloud.vasile.TLD

Contents of /usr/local/apache/conf.d/vhosts-ssl-letsencrypt.conf:

# vhost_start cloud.vasile.TLD
<VirtualHost 100.100.100.100:443>
 ServerName cloud.vasile.TLD
 ServerAdmin mail@mail
  DocumentRoot /home/vasile/public_html/cloud
 SSLEngine on
 SSLCipherSuite ALL:!ADH:RC4+RSA:+HIGH:+MEDIUM:-LOW:-SSLv2:-EXP:!kEDH:!aNULL
 SSLProtocol All -SSLv2 -SSLv3
 SSLCertificateFile /etc/letsencrypt/live/cloud.vasile.TLD/cert.pem
 SSLCertificateKeyFile /etc/letsencrypt/live/cloud.vasile.TLD/privkey.pem
 SSLCertificateChainFile /etc/letsencrypt/live/cloud.vasile.TLD/fullchain.pem
 SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
<IfModule mod_suexec.c>
    SuexecUserGroup vasile vasile
</IfModule>
<IfModule mod_suphp.c>
    suPHP_UserGroup vasile
    suPHP_ConfigPath /home/vasile
</IfModule>
<Directory "/home/vasile/public_html/cloud">
    AllowOverride All
</Directory>
</VirtualHost>
# vhost_end cloud.vasile.TLD

status.php:
{"installed":true,"maintenance":false,"version":"9.1.3.1","versionstring":"9.1.3","edition":""}

config.php:

<?php
$CONFIG = array (
  'instanceid' => '**************',
  'passwordsalt' => '******************',
  'secret' => '**********************',
  'trusted_domains' => 
  array (
    0 => 'cloud.vasile.TLD',
  ),
  'datadirectory' => '/home/vasile/public_html/cloud/data',
  'overwrite.cli.url' => 'https://cloud.vasile.TLD',
  'dbtype' => 'mysql',
  'version' => '9.1.3.1',
  'dbname' => 'vasile_cloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'vasile_cloud',
  'dbpassword' => 'XXXXX',
  'logtimezone' => 'UTC',
  'installed' => true,
);

Any ideas? because from a few days I'm completely lost.. :expressionless:


#2

So you have fixed the "Your web server is not yet set up" message? If not this needs to be fixed within your webserver or you can't use ownCloud. All needed info how to fix your webserver are available here:


#3

Hello kljhlkhglklfgh and thank you for your answer.
I don't know why that error, because when I try to access the WebDAV, I got this:

This is the WebDAV interface. It can only be accessed by WebDAV clients such as the ownCloud desktop sync client.

so I guess somehow it's working, right?


#4

Nope, this is no sufficient check if the WebDAV interface is working. The "Your web server is not yet set up" is doing an active check and shows that your WebDAV interface is broken. Please work your way trough the mentioned FAQ above.

You can e.g. run the litmus test mentioned there which is most likely also failing.


#5

Hello,
I tried to install litmus, but obviously I had problems with some dependencies and I let it go.
Anyway, after allot of search, changing PHP version and recompiling Apache, I made it work!

I use now PHP 5.5.30, Apache 2.2.27 and in .htaccess from the cloud directory I added at the top those lines:

<Limit GET POST OPTIONS PROPFIND PUT>
                Order allow,deny
                Allow from all
        </Limit>
        <LimitExcept GET POST OPTIONS PROPFIND PUT>
                Order deny,allow
                Deny from all
        </LimitExcept>

Thank you very much for your help. I knew it it was a mistype configuration in Apache.. :slight_smile: