Unable to Access Owncloud applicance from Static Public IP and error while joining AD


#1

Hello,
I have just installed owncloud virtual machine in Windows server 2012 r2, I can able to connect ip address https://192.168.1.110 via my browser, however I am unable to connect from desktop client with the this ip address https://staticpublicipaddress/owncloud. I am getting the error HTTP Error 404. The requested resource is not found. Please help me in this regards.

Thank you.


#2

Hi, how did you setup the appliance on your windows server?

have you integrated it in your domain?

Have you a dns server, if yes, do you have a DNS entry for that domain?

If you don't have a DNS server, have you modified your hosts file to resolve the ip to the hostname?


#3

Thank you for your reply Dmitry.

I have expected this question from you. Yes, you are right, I haven't done anything and I have thought that appliance will autodetect everything, foolish of me, apologies. Need your guidance more into this.

I have my domain and DNS setup on the server. Would you mind please guide me how to integrate appliance into windows server?

Thank you again.


#4

I would reinstall the appliance, and during the setup, choose the "integrate the appliance in my active directory" option.

The appliance can only do so much, some things you have to do yourself :slight_smile:

Or - if you don't want to reinstall it - you can just simply edit your hosts file and enter the Appliance's Ip address and domain name.


#5

Thank you again for the prompt reply. I will do the configuration again as per it's requirement and will update you further.

Thanks indeed again.


#6

Hi Dmitry,

I am trying to reinstall the appliance, it detected domain name correctly however unable to join in domain, it throws the following error "The connection to the active directory is refused please check the password" although I have entered password correctly.
Any suggestions please.

Thank you.


#7

Hi,

with what account are you trying to connect?

It has to be a domain admin, who has the permissions to join a server to a domain.


#8

Hi,

Administrator Account. It has a full permissions.

Thank you.


#9

Well, it seems like you are doing everything right.

I can't say for sure, since I don't have access to your setup :slight_smile:

You can setup the appliance as before, and edit the hosts file.


#10

Hi Dmitry,

1) I have edited host file and map the own cloud private IP to hostname, and internally able to browse with a name.
2) When my public IP address hits my Linksys dd-wrt router, what ports should I open and forward? All problem lies here, any suggestions, please.
3) When https://publicip/owncloud hits the router, how is it going to forward the request to private IP 192.168.1.120/owncloud?

Look forward your kind reply.

Thanks, much !!


#11

I suppose that's a networking issue, not really a ownCloud issue :slight_smile:

Since you are accessing ownCloud via http - port 80.
If you accessing ownCloud via https - port 443.

You also can configure your Web Server to use different ports.


#12

Hi Dmitry,

I have one public static IP Address which is assigned to our router, with that IP Address, I can be able to access Windows Server, but not VirtualHost Owncloud which was already bridged into Server.

I think some ports have to be open in router side, May I know any specific Owncloud ports are there which has to be open and port forwarding on the router, please advise me.

Thanks and regards,

Rizwan


#13

There are no specific ports for ownCloud AFAIK.

Can you tell me how you imported the appliance on your windows server?

Have you a VM with linux on it, or was it the appliance?

If it's the appliance - did you use Hyper-V or Virtual Box as the virtualizer?

How did you set the network settings on those VMs? If it's NAT - it could be difficult. I would change it to Bridged Mode.

I suppose on your Router you would have to open A port. Like Port 80, and the target private ip of your server.

If you can access your server from outside with the IP, you should be able to access owncloud by typing IP/owncloud


#14

Thank you for you reply Dmitry.

1) I have installed the Owncloud appliance on VirtualHost. No other Linux OS is running else than Virtual Appliance.
2) It has been set to Bridged Network Adapter.
3) I can access my Windows Server via Remote Desktop, FTP
4) I have already opened the port 80, 443, 8080, for Owncloud private IP Address such 192.168.1.150
5) My Windows Server IP is 192.168.1.149 and Owncloud appliance IP is 192.168.1.150 and I have only ONE static public IP to connect both.
6) When I enter https with staticpublicip/owncloud or http with staticpublicip/owncloud are unable to access via webpage. Even on an Owncloud desktop client, I am getting following error messages
Failed to connect to Owncloud at https://staticpublicip/owncloud
Server replied "404 Not Found" to "GET https://staticpublicip/owncloud/owncloud/status.php"

Thanks in advance and appreciate your help.


#15

Can you post your apache2 conf.

The sites enabled / availiable for http and https

default and defaultssl.conf


#16

Hi Dmitry, I will paste it ASAP


#17

Hi Dmitry,

Eureka! Eureka!

The troubleshooting is simple but I took a long time to notice it.

Port 443 has been forwarded to Windows Server IP as well as Owncloud Server IP. When any public IP hits my router, it gets confused where to route 443 requests into LAN. So I have removed port 443 forwarding for Windows Server Private IP Address and Owncloud able to sail through smoothly. Now I can able to access Owncloud from my static public IP Address through the Web browser and desktop client.

Forum Admin can mark this post has been solved.

I have more queries and will create another post thread for that.

Thank you indeed, Dmitry, for your kind replies and productive solutions.


#18

Thanks for sharing your solution with the forum :slight_smile:


#19

Hi Compeec,i also have the problem as you showed. I want to know whether you just removed port 443,and you problem be solved.


#20

Hi,

you can use "@" to mention specific users :slight_smile:

like @Compeec