Updater index.php/occ/config:list 405 when updating to 9.1.2 (docker)

upgrade
9.1.x
help

#1

When I try to update from 9.1.1 to 9.1.2 I get the error noted below.
I don't really need anything from this update, but I like to stay up to date.

Steps to reproduce
1. Login to admin account
2. Open admin management page
3. Click "open updater" in updater section.

Expected behaviour
Owncloud should update :stuck_out_tongue:

Actual behaviour
During the "initializing" fase, I get this error:

[GuzzleHttp\Exception\ClientException] e
Client error response [url] https://domain/index.php/occ/config:list [status code] 405 [reason phrase] Method Not Allowede

I tried doing manual upgrading procedures, but I can't kill the webserver since that brings the docker container down.

Server configuration

I'm using the 'official' docker image for owncloud.

Operating system: Debian linux
Web server: apache2
Database: mariadb running in different container
PHP version: Zend Engine v2.6.0 with Zend OPcache v7.0.6-dev
ownCloud version (see ownCloud admin page): 9.1.1
Updated from an older ownCloud or fresh install: Fresh install
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):
External storage, reverse proxy. Ask if you want configs. I think the issue has to do with the reverse proxy
ownCloud log (data/owncloud.log)

No errors related to the updating proces.

Integrity status for oC9+

No errors have been found.

#2

I haven't worked with the docker image yet. But are you supposed to use the updater app? Isn't there a docker-procedure to update?
The updater app is known to be a bit buggy, and if it doesn't work in your environment, the easiest solution is probably to make a manual update.


#3

I think I might try deleting the container (since the data is stored outside of the container), then pull a newer image and recreate the container. I can't do a manual (download the zip file, extract etc.) update because when I kill the webserver, the whole container stops. I think I'm going to try the "docker update" way of updating, although I don't know if doing it like that will allow the database & data storage to update correctly.


#4

You can't use the updater app from 9.1.0/9.1.1 to go to 9.1.2/9.1.3 without applying the patches mentioned here:


#5

Last week I was finally able to update.

I tried applying the patch, but running the updater afterwards yielded same results. Then, after carefully backing up everything, I tried @tflidd's idea.
I deleted the old container, pulled a new version of the image, and reissued the docker command that I used to create the previous instance of the container. After the container started up, it showed me the update page, and it updated successfully.

Now happily running 9.1.2 :wink:

Cheers, and happy Holidays!