"Patches for known update issues from version 9.0.4, 9.0.5, 9.1.0, 9.1.1

update
help

#1

Notes on using built-in updater

Affects ownCloud versions 9.0.4, 9.0.5, 9.1.0 and 9.1.1 only

Fixes the following issues:

  • Updater web interface shows:

    [UnexpectedValueException] 
     Could not parse a response for config:list. Please check if the current shell user can run occ command.
     Raw output: 
     Not allowed
  • Exception in CLI mode:

    [Symfony\Component\Process\Exception\ProcessFailedException]                                                  
      The command "php /usr/local/www/owncloud/occ --no-warnings app:list --output=json '--shipped false'" failed.  
      Exit Code: 1(General error)                                                                                   
      Output:                                                                                                       
      ================                                                                                              
      Error Output:                                                                                                 
      ================                                                                                              
    
        [Symfony\Component\Console\Exception\RuntimeException]                                                      
        The "--shipped false" option does not exist.                                                                
    
      app:list [--output [OUTPUT]] [--shipped SHIPPED]
  • PHP 5.4 incompatibility:

    Fatal error: Can't use method return value in write context in 
    updater/src/Console/Application.php on line 193
  • Complain on Integrity check in admin area after update is done

Patches:

Patch for 9.0.4 and 9.0.5
Patch for 9.1.0 and 9.1.1

Complete list of steps to apply the patch for 9.0.4 and 9.0.5

1. cd /path/to/owncloud/dir
2. wget https://gist.githubusercontent.com/VicDeo/b423a50776440c7b4a10f55ce0068845/raw/4ca6092ee5bff3157efacb5b96dfa46255a65bb7/updater-904-905.patch
3. patch -p0 <updater-904-905.patch
4. rm updater-904-905.patch

Complete list of steps to apply the patch for 9.1.0 and 9.1.1

1. cd /path/to/owncloud/dir
2. wget https://gist.githubusercontent.com/VicDeo/937a0172a06d693258b97b7132c4ba5b/raw/193a6c3f993adfe78ea26d92f2f916ac09dddc42/updater-910-911.patch
3. patch -p0 <updater-910-911.patch
4. rm updater-910-911.patch

Already patched files

If you have no shell access you can download already patched files:

  1. Check your version
  2. Download respective version package from the list below
  3. Extract it
  4. browse into patched-90x or patched-91x directory
  5. FTP all files from this directory into your owncloud root dir overwriting existing files

9.0.4 and 9.0.5 https://github.com/owncloud/updater/files/563026/patched-90x.zip
9.1.0 and 9.1.1 https://github.com/owncloud/updater/files/563022/patched-91x.zip


Updater in 9.1.0 not working after patch
9.0.4 patch doesn't work for me
Owncloud upgrade error
Update server deployed for 8.0.15, 8.1.10, 8.2.8, 9.0.5, 9.1.1
Updater Bug Version 9.0.4 to 9.0.5
OC Updater: cURL error 60: SSL certificate problem: unable to get local issuer certificate
Owncloud upgrade error
Updater index.php/occ/config:list 405 when updating to 9.1.2 (docker)
Update troubles using the updater
Can I get a simple answer to the following - it really would help
Anyone can help me to update owncloud
Keine automatische Synchronisation Linux Mint 18
#2

For reference, the patches are based on many of these fixes:
- https://github.com/owncloud/updater/pull/394
- https://github.com/owncloud/updater/pull/395
- https://github.com/owncloud/updater/pull/397
- https://github.com/owncloud/updater/pull/398
- https://github.com/owncloud/updater/pull/400
- https://github.com/owncloud/updater/pull/405


#3

#4

After applying patch for 9.1.0 and trying to update to 9.1.1 I get the error: cURL error 35: error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown protocol


#5

Not related to the patches. I'm also closing this issue to avoid further hijacking of this post.

If some one has any questions to these please create a new thread.


#6

It's show error message when I upgrade from 9.1.0 to 9.1.1