Upgrade to The username is already being used

docker
upgrade
10

#1

Configuration is as follows:
OWNCLOUD_DOMAIN=yp.mapbar.com
OWNCLOUD_ADMIN_USERNAME=admin
OWNCLOUD_ADMIN_PASSWORD=yp111qqq,
OWNCLOUD_VERSION=10.0.8
OWNCLOUDPATH=/mapbar/data/owncloud/data/owncloud
docker run -d
–name owncloud
–link mariadb:db
–link redis:redis
-p 80:80
-p 443:443
-e OWNCLOUD_DOMAIN=${OWNCLOUD_DOMAIN}
-e OWNCLOUD_DB_TYPE=mysql
-e OWNCLOUD_DB_NAME=owncloud
-e OWNCLOUD_DB_USERNAME=owncloud
-e OWNCLOUD_DB_PASSWORD=owncloud
-e OWNCLOUD_DB_HOST=db
-e OWNCLOUD_ADMIN_USERNAME=${OWNCLOUD_ADMIN_USERNAME}
-e OWNCLOUD_ADMIN_PASSWORD=${OWNCLOUD_ADMIN_PASSWORD}
-e OWNCLOUD_REDIS_ENABLED=true
-e OWNCLOUD_REDIS_HOST=redis
-v $OWNCLOUDPATH:/mnt/data:z
-v /mapbar/data/owncloud/data/autoai-sslkey:/mnt/data/certs
owncloud/server:${OWNCLOUD_VERSION}

After upgrading from 10.0.8 to 10.0.10, start a new mirror and report an error
Restore to 10.0.8 and the startup still reports an error
Reconstruction can be resolved, but the configuration is lost


#2

What error in particular?


#3

This is the container’s error log:

Creating volume folders…
Creating hook folders…
Waiting for MySQL…
wait-for-it: waiting 180 seconds for db:3306
wait-for-it: db:3306 is available after 0 seconds
Waiting for Redis…
wait-for-it: waiting 60 seconds for redis:6379
wait-for-it: redis:6379 is available after 0 seconds
Removing config folder…
Linking config folder…
Writing config file…
Fixing base perms…
Fixing data perms…
Fixing hook perms…
Installing server database…
The username is already being used


#4

Who can help me solve it


#5

You have to delete the already existing db user owncloud.