Virtual File Sync no longer working properly

Expected behaviour

Expecting all my virtual files to appear.

Actual behaviour

My files that are not within folders appear but not the files that are in folders.
The folders are created but without any files inside.
A few seconds after the initial sync. The client thinks the files are deleted and proceed to delete them from the server as well. Had to restore from the Recycle Bin (thank god for that).

The virtual files were working correctly up until I uninstalled OneDrive and Microsoft Teams… I’m unsure if it’s a coincidence or not.

Steps to reproduce

  1. Configure a folder sync and choose virtual sync method.

Server configuration

Operating system: Debian 10.4

Web server: Apache 2

Database: MySQL

PHP version: PHP 7.2.31-1+0~20200514.41+debian10~1.gbpe2a56b

ownCloud version: ownCloud 10.4.1 (stable)

Storage backend (external storage):

Client configuration

Client version: 2.7.2.2626

Operating system: Windows 10 (latest updates and fresh install)

OS language: English

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client: Default

Logs

Please use Gist (https://gist.github.com/) or a similar code paster for longer
logs.

Template for output < 10 lines

  1. Client logfile: Output of owncloud --logwindow or owncloud --logfile log.txt
    (On Windows using cmd.exe, you might need to first cd into the ownCloud directory)
    (See also http://doc.owncloud.org/desktop/2.2/troubleshooting.html#client-logfile )

  2. Web server error log:

  3. Server logfile: ownCloud log (data/owncloud.log):

We’re having the same issue

We have the same problem, and “lost” (had to restore) thousand files.

Hey,

this sounds to me more like a bug in the sync client so i think this is better raised as an issue for the ownCloud people at https://github.com/owncloud/client/issues

Same problem here. Looks like a windows update, some client have the problem, some not.

Thanks for all your feedback!!

Development team is working on a quick solution. You can track the progress here:
https://github.com/owncloud/client/issues/8295

2 Likes

Hey,

it seems that this has been already fixed in a new version of the Windows sync client:

1 Like

yes, it was fixed today after I posted this issue.
It is now resolved but I did have to completely uninstall the desktop client and reinstall for the Virtual Files to work properly.

Thanks for the quick resolution!

2 Likes

I run owncloud 10.5.0.10 on ubuntu 18.04 and desktop client 2.7.4 (build 2934) on Win 7.

My desktop files are not in sync too. Sync gets stuck every 2 min writing “merge”, but it will never finsh merging one file which I deleted on server. I also can not open directories from owncloud on my local machine. And my owncloud Server broke down this night. I had to reboot it. Dont know if that has something to do with desktop client.

Please help.

Can you see something in the log files (form server or sync-client) that could show us the behaviour?

1 Like

I found the reason. Target file on external storage is removed to quickly from another process on external storage. owncloud tries to copy it 2nd time, but fails again cause of removal. To avoid this error the file on external stroage shoud not be removed within 2 minutes.

But now I run into another issue. If a file is removed (deleted) on external storage there will come up a warning asking if you want to keep or delete your local file.

Picture0001

Is there a possibility to disable this question and silently delete the local file?

You can set promptDeleteAllFiles to false in the config file:
https://doc.owncloud.com/desktop/advanced_usage/configuration_file.html

1 Like

I am having this/similar issue also.

I have spontaneous (not user action) deletion of files.
Files and folders are under a shared top level folder.

All users are normally using the WIndows 10 client, but also occasionally web interface.

This is a fresh server installation from univention UCS app repo.
The clients are all 2.7.4 and these are the only owncloud clients ever installed.

Users are authenticated using LDAP and client machines are part of an AD (Samba) domain.

On any one client machine there may be more than one user login (not simultaneous) and correspondingly a unique owncloud client folder under each windows user account.

The deleted files can be found via the web interface and restored.

It seems a serious problem as it is quietly eating away at our data with no warning unless somebody spots something is missing.

The deleted files may be found in the deleted