Web UI: Redirecting Please wait a while. You are being redirected

Steps to reproduce

  1. Followed instructions on Deploy as an app in ownCloud 10 | ownCloud
  2. Logged in ownCloud
  3. Clicked on “New Design”
  4. Authorised Access

Expected behaviour

I should be able to see the Web UI interface instead of the Classic interface

Actual behaviour

Redirecting Please wait a while. You are being redirected
Nothing happens after showing that message.

Server configuration

Operating system : Debian 10

Web server: Apache

Database: MariaDB 10.3.29

PHP version: 7.3.29

ownCloud version: 10.8

The log file doesn’t show any errors.
The “Web” app is installed udner apps-external folder instead of apps folder.

I too am seeing this behaviour - I’ve been through the config so many times iwith the installation guide and can’t figure out what might be going on. I have some JS errors, e.g. failed to load app undefined TypeError: t is undefined in web-runtime-6f65a499.js:1:68898.

Is there anyone who can help with this? I’ve just updated to Web 4.2.0 (OC 10.8) and it’s still happening.

In Chrome the error I’m currently getting is:

Uncaught (in promise) Invalid query, please check the syntax. vendor-fee82cbd.js:12

I have exactly the same problem.
Hardware RaspberryPi4
ownCloud 10.8.0
Web 4.2.0

Have you found a solution yet? I hardly can find anyone else with the problem, no official information so far.

Kind regards

No, nothing at all. Other topics have had official help / responses since, so I’m not sure why this one has been ignored.

1 Like

It’s likely a setup problem, but it’s difficult to pinpoint where is problem with such a little information. There are quite a bunch of manual steps to do, and it’s easy to mess something up.

Maybe you could post what you do, step by step, using a fake server name. It’s likely a wrong url, but it’s difficult to know which one.

Hardware: Raspberry Pi 4B
OS: Raspbian Buster
Webserver: nginx/1.14.2
Database: 10.3.29-MariaDB-0+deb10u1
PHP version: PHP 7.3.29-1~deb10u1
ownCloud version: 10.8

  1. I installed github/owncloud/web

  2. I added this to my config.php

‘web.baseUrl’ => ‘blackhole/index.php/apps/web’,
‘web.rewriteLinks’ => true,

  1. This is my owncloud/config/config.json
    { "server" : "https://blackhole", "theme": "https://blackhole/apps/web/the - Pastebin.com
    Since I am a new user I can only provide 2 urls and I am not able to upload a text file… :confused:

  2. I installed oauth2 from here: github/owncloud/oauth2

  3. I added a Client in the oauth2 App called OWeb, URI = blackhole/index.php/apps/web/oidc-callback.html took the clientid and saved it in the config.json

Everything seems to work except it doesnt redirect as explained earlier and the dev console is showing: Uncaught (in promise) Invalid query, please check the syntax. API specifications - Pastebin.com

Does that help to better investigate? I am thankful for any hint!

It works for me. Checked with OC 10.8, oauth 0.5.0, and web 4.2.0

@Koaebk

  • Double-check both apps are downloaded from the marketplace. You might want to use the “market” app for this. Some apps might require some build steps if you’re downloading the source code, and the apps in the marketplace are already built and ready to use, so no need for you to bother with additional things.
  • The “web.baseUrl” config option requires the whole url, including the protocol. This means https://blackhole/index.php/apps/web (I’m not sure if it will work with http, probably not)
  • For the oauth2 client, the uri also requires the protocol: https://blackhole/index.php/apps/web/oidc-callback.html

There is a 404 for the theme, you might want to remove it, although the web app works fine with that. Other than that, it works for me with those steps

1 Like

I only removed the https:// part in order to be able to post it here, since I wasnt allowed to post more than 2 urls as a newbie.

It is included in my config. I uninstalled and reinstalled both apps from the marketplace. I also tried disabling my theme. No changes sadly :frowning:

Are you using apache? This might be the difference.

Yes, I’m using apache.

I’ve tried many more times, but I always get the same problem again and again.
It seems to work, it authenticates, but then it gets stuck on this screen:

Screenshot from 2021-10-08 17-49-35

I cant’ see anything in the log file that is related to a possible issue with the configuration.