Windows client does not connect with server

cpanel
help
webserver_issue

#1

Dear support team,

please help to solve the issue of not beeing able to use desktop client while he is not connecting to server.
BR, Alex

Please help us by providing the following info. Before posting please make sure that you're running the latest available version for your oC release:

server version 9.1.4

Steps to reproduce
1. login via browser is working proper
2. installed desktop client
3. login is impossible "access from server denied"
Screen shot > https://www.screencast.com/t/5xcc2pem1

Expected behaviour
shall connect and sync with server

Actual behaviour
no connection possible

Client configuration
Client version: 5.6.2
Client operating system: winows 7

Server configuration
Operating system: cPanel
Web server: linux
Database: mysql
PHP version:5.6
ownCloud version (see ownCloud admin page): yes
Updated from an older ownCloud or fresh install: no
Special configurations (external storage, external authentication, reverse proxy, server-side-encryption): no

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

{"reqId":"WMwbzn6neoH3GBjn8xpAlgAAAAY","remoteAddr":"80.147.238.99","app":"base","message":"Exception: {\"Exception\":\"ErrorException\",\"Message\":\"Cannot modify header information - headers already sent\",\"Code\":0,\"Trace\":\"#0 [internal function]: OC\\\\Session\\\\Internal->trapError(2, 'Cannot modify h...', '\\\/home\\\/worldchec...', 50, Array)\\n#1 \\\/home\\\/worldcheckin\\\/public_html\\\/wci\\\/cloud\\\/owncloud\\\/lib\\\/private\\\/Session\\\/Internal.php(50): setcookie('ocsa94nrc5ng', '', -1, '\\\/cloud\\\/owncloud')\\n#2 \\\/home\\\/worldcheckin\\\/public_html\\\/wci\\\/cloud\\\/owncloud\\\/lib\\\/base.php(427): OC\\\\Session\\\\Internal->__construct('ocsa94nrc5ng')\\n#3 \\\/home\\\/worldcheckin\\\/public_html\\\/wci\\\/cloud\\\/owncloud\\\/lib\\\/base.php(575): OC::initSession()\\n#4 \\\/home\\\/worldcheckin\\\/public_html\\\/wci\\\/cloud\\\/owncloud\\\/lib\\\/base.php(973): OC::init()\\n#5 \\\/home\\\/worldcheckin\\\/public_html\\\/wci\\\/cloud\\\/owncloud\\\/index.php(52): require_once('\\\/home\\\/worldchec...')\\n#6 {main}\",\"File\":\"\\\/home\\\/worldcheckin\\\/public_html\\\/wci\\\/cloud\\\/owncloud\\\/lib\\\/private\\\/Session\\\/Internal.php\",\"Line\":145}","level":3,"time":"2017-03-17T17:24:31+00:00","method":"POST","url":"\/cloud\/owncloud\/index.php\/heartbeat","user":"--"}
{"reqId":"WMwbzn6neoH3GBjn8xpAlgAAAAY","remoteAddr":"80.147.238.99","app":"index","message":"Exception: {\"Exception\":\"ErrorException\",\"Message\":\"Cannot modify header information - headers already sent\",\"Code\":0,\"Trace\":\"#0 [internal function]: OC\\\\Session\\\\Internal->trapError(2, 'Cannot modify h...', '\\\/home\\\/worldchec...', 105, Array)\\n#1 \\\/home\\\/worldcheckin\\\/public_html\\\/wci\\\/cloud\\\/owncloud\\\/lib\\\/private\\\/legacy\\\/response.php(105): header('HTTP\\\/1.1 500 In...')\\n#2 \\\/home\\\/worldcheckin\\\/public_html\\\/wci\\\/cloud\\\/owncloud\\\/lib\\\/base.php(438): OC_Response::setStatus(500)\\n#3 \\\/home\\\/worldcheckin\\\/public_html\\\/wci\\\/cloud\\\/owncloud\\\/lib\\\/base.php(575): OC::initSession()\\n#4 \\\/home\\\/worldcheckin\\\/public_html\\\/wci\\\/cloud\\\/owncloud\\\/lib\\\/base.php(973): OC::init()\\n#5 \\\/home\\\/worldcheckin\\\/public_html\\\/wci\\\/cloud\\\/owncloud\\\/index.php(52): require_once('\\\/home\\\/worldchec...')\\n#6 {main}\",\"File\":\"\\\/home\\\/worldcheckin\\\/public_html\\\/wci\\\/cloud\\\/owncloud\\\/lib\\\/private\\\/Session\\\/Internal.php\",\"Line\":145}","level":3,"time":"2017-03-17T17:24:31+00:00","method":"POST","url":"\/cloud\/owncloud\/index.php\/heartbeat","user":"--"}
{"reqId":"WMwbzn6neoH3GBjn8xpAlgAAAAY","remoteAddr":"80.147.238.99","app":"PHP","message":"ErrorException: Cannot modify header information - headers already sent at \/home\/worldcheckin\/public_html\/wci\/cloud\/owncloud\/lib\/private\/Session\/Internal.php#145","level":3,"time":"2017-03-17T17:24:31+00:00","method":"POST","url":"\/cloud\/owncloud\/index.php\/heartbeat","user":"--"}

#2

Are you using the current client version 2.3.1 (5.6.2 does not exist)?
You can check separately if the webdav interface is set up correctly (cyberduck, winscp, ...), there is a general troubleshooting guide for client issues:
https://doc.owncloud.org/desktop/2.3/troubleshooting.html


#3

Hi,
thanks for info. Yes I am using 2.3.1 as client version.

I will test now by using the troubleshooting guide and provide you know with these details to may helpful for solving.

04-13 11:41:36:102 11600 OCC::OwncloudSetupWizard::slotConnectToOCUrl: Connect to url:      "https://www.worldcheckin.com/cloud/owncloud/"
04-13 11:41:36:103 11600 OCC::OwncloudWizard::appendToConfigurationLog: Setup-Log:  "Verbindungsversuch mit ownCloud unter https://www.worldcheckin.com/cloud/owncloud/…"
04-13 11:41:36:104 11600 OCC::AbstractNetworkJob::start: !!! OCC::PropfindJob created for "https://www.worldcheckin.com/cloud/owncloud" + "/" "OCC::OwncloudSetupWizard"
04-13 11:41:36:428 11600 OCC::HttpCredentials::slotAuthentication: Stop request: Authentication failed for  "https://www.worldcheckin.com/cloud/owncloud/remote.php/webdav/"
04-13 11:41:36:429 11600 OCC::AbstractNetworkJob::slotFinished: void OCC::AbstractNetworkJob::slotFinished() QNetworkReply::NetworkError(OperationCanceledError) "Operation abgebrochen" QVariant(Invalid)
04-13 11:41:36:430 11600 OCC::PropfindJob::finished: PROPFIND request *not* successful, http result code is 0 ""

BR, Alex


#4

Good, so your client can connect to your server, did you try to access directly via webdav?

We have also a large howto with many possible issues regarding webdav:

It's a long list and a bit complicated, especially when using administration tools such as cPanel because they do some default settings and changing these can be a bit complicated and needs deeper knowledge of the admin tool you are using.


#5

Did you have more success with 2.3.1?

Are you using PHP-FPM on your server?


#6

Hi again,

meanwhile we could have solved this by changing some server settings.
Here is the info I got from server admin:
FYI: We have configured authorization within domain vhost for resolving the issue.

BR, Alex