You don’t have permission to upload or create files here

help

#1

I have installed in our hosting server; but am not able to upload the files to shared folder, whenever i try to upload files show error " You don’t have permission to upload or create files here ownCloud Files" In own Cloud 9.0 Version


"You don’t have permission to upload or create files here"
#2

The person, which shared the folder with you did not enable option "enable upload to folder" in the folder's sharing tab. If that is not the case, we will go further with the issue :slight_smile:


#3

Hi

Thank you for your response; in admin User only am trying to upload; i here by enclosed screenshot

awaiting for reply

Thanks & Regards
Santhosh


#4

In that case your webserver probably has not the permission to write to your data-directory (get the path in your config/config.php)


#5

I got the data path from config file and I set all read,write, execute permission to data folder using ftp filezilla; but still facing same permission error ; file permission details enclosed.


#6

The problem migth not only be the read/write permissions, but also ownership of the file (chown). You also need to give this rigths recursively to all the subdirectories and files.

About correct permissions, please follow the manual:

https://doc.owncloud.org/server/9.0/admin_manual/installation/installation_wizard.html#strong-perms-label


#7

I don't have this option in the sharing tab of folders. Using OC 9.1.2 (stable).
And I can't find any mention of this option anywhere else in OwnCloud documentation.


#8

On recent oC versions its called "Allow editing" and can be found in the details view of a folder when sharing it. This requires that you have enabled "Allow public uploads" in your admin backend.


#9

Bingo! It works, thank you.

Such an awesome feature of OC!


#10

Fixing permissions in the CLI worked for me. I had only given the www user (www-data) permissions to the main folder in users directory under the owncloud data directory. Deeper inside, the files and directories were owned by root from when I originally moved them over to the user folder

I used the command "chown -r www-data:www-data *" inside /home/clientdata/user/files/exampledirectory directory and it recursively gave ownership to the www user. I then logged into the web interface and the permissions error notice was gone.


"You don’t have permission to upload or create files here"