Calendar sharing does not work since upgrade to 10.0

possible_app_bug
calendar
upgrade
10

#1

Steps to reproduce
1. using ubuntu 16.04 and installed owncloud from recommended STABLE repository as descriped in https://download.owncloud.org/download/repositories/stable/owncloud/
2. automatic package upgrade occured (i am using cron-apt) for following packages: owncloud owncloud-deps-php7.0 owncloud-files => upgrade from 9.1.5.2 to 10.0.0
3. i manually disabled the calendar app (occ spp:disable calendar) to bring upgrade to work (as described in "known bugs")
4. known issue inhibited upgrade (https://github.com/owncloud/core/issues/27754), so i generated the missing databasefield "publicuri"
5. activated / updated to new calendar app in webinterface (market)
6. all seems to work now, including calendar in webinterface - but not synchronizing with mobile devices using caldav

Expected behaviour
1) calendars in mobile clients (android) should synchronize
1a) for own calendar(s)
1b) for calendar(s) shared from other user

Actual behaviour
1. connection broken => no sync => so i newly created an caldav account with the new address (example.com/owncloud/remote.php/dav), which now works for me, BUT: all users have to change this in their devices => very user-unfriendly
2. tried to share a calendar from one user to another (webinterface), but this doesn't work: after typing in a valid username, the line to checkmark "may change" ("kann bearbeiten") does not appear.

Server configuration
Operating system: ubuntu 16.04
Web server: Apache/2.4.18 (Ubuntu)
Database: mysql
PHP version: 7.0.15-0ubuntu0.16.04.4
ownCloud version (see ownCloud admin page): 10.0.0.12
Updated from an older ownCloud or fresh install: 9.1.5.2
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): no

ownCloud configuration

Go to the admin page, click on 'admin' -> 'Generate Config Report' -> 'Download ownCloud config report' or use the command line `sudo -u www-data php occ config:list system` (please sanitize sensitive data):
{
    "basic": {
        "license key": "",
        "date": "Sun, 30 Apr 2017 06:03:26 +0000",
        "ownCloud version": "10.0.0.12",
        "ownCloud version string": "10.0.0",
        "ownCloud edition": "Community",
        "server OS": "Linux",
        "server OS version": "Linux kudahms.de 4.4.0-042stab120.18 #1 SMP Fri Jan 13 10:32:04 MSK 2017 x86_64",
        "server SAPI": "apache2handler",
        "webserver version": "Apache\/2.4.18 (Ubuntu)",
        "hostname": "kudahms.de",
        "user count": 8,
        "user directories": 8,
        "logged-in user": "uwe"
    },
    "config": {
        "updatechecker": false,
        "instanceid": "ocjm2jb6whjw",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
            "kudahms.de",
            "v43439.1blu.de"
        ],
        "datadirectory": "\/var\/www\/owncloud\/data",
        "overwrite.cli.url": "http:\/\/kudahms.de\/owncloud",
        "dbtype": "mysql",
        "version": "10.0.0.12",
        "dbname": "oc",
        "dbhost": "localhost",
        "dbtableprefix": "oc_",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "logtimezone": "Europe\/Berlin",
        "installed": true,
        "overwriteprotocol": "https",
        "maintenance": false,
        "mail_from_address": "u.dahms",
        "mail_smtpmode": "php",
        "mail_domain": "arcor.de",
        "theme": "",
        "loglevel": 3,
        "enable_previews": true,
        "memcache.local": "\\OC\\Memcache\\APCu"
    },
    "integritychecker": {
        "passing": true,
        "enabled": true,
        "result": []
    },
    "core": {
        "backgroundjobs_mode": "cron",
        "installedat": "1475784193.2007",
        "lastcron": "1493532001",
        "lastupdateResult": "[]",
        "lastupdatedat": "1493532146",
        "public_files": "files_sharing\/public.php",
        "public_webdav": "dav\/appinfo\/v1\/publicwebdav.php",
        "repairlegacystoragesdone": "yes",
        "shareapi_allow_public_notification": "yes",
        "umgmt_send_email": "true",
        "umgmt_show_backend": "false",
        "umgmt_show_email": "true",
        "umgmt_show_last_login": "true",
        "umgmt_show_storage_location": "false",
        "vendor": ""
    },
<<<clipped>>>

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

#2

This was also reported in https://central.owncloud.org/t/calendar-contact-sync-problem/7327 but the user havn't managed to create a new bugreport as requested there. So please create a new bugreport at https://github.com/owncloud/core/issues

This was also reported in https://central.owncloud.org/t/kalenderfreigabe-nicht-mehr-moglich/7329 but the users havn't managed to create a new bugreport as requested there. So please also create a new bugreport at https://github.com/owncloud/calendar/issues

Both are issues where we users in here can't help with. And if none of you having this issues are reporting them to the developers the issues stays unfixed.


#3

issue opened:


#4

here is the fix for the broken sync - please test - thx