Can't even perform basic install?

Steps to reproduce

  1. Create database. Create user. Apply all privs to the DB using MySQL.
  2. Use browser to view first page to create admin name and input DB name and user and password.
  3. After hitting enter, receive a pop up error indicating it cannot create Admin.

Expected behaviour

Tell us what should happen
What should happen is the Admin user should be created and should be logged into the first initial screen.

Actual behaviour

Tell us what happens instead
A popup error comes up instead, which is attached.

Server configuration

Operating system:
Linux VPS

Web server:
Apache 2.4 PHP 7.0

MariaDB/SQL 10.2

PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:

Where did you install ownCloud from:
SSH and Browser

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into and puth the link here.

Cannot get that far. See attached error.

The content of config/config.php:
$CONFIG = array (
'instanceid' => 'ocz7k81uiphp',
'passwordsalt' => '5rt3RRVdCGiuLbAi4G7hanR3Qu7NGA',
'secret' => '8ej/zNzDJVYutjJ3uEPEubU7xPPPPmEsoLZrG5L3wwBsVVno',
'trusted_domains' =>
array (
0 => '',
'datadirectory' => '/home/domain/public_html/data',
'overwrite.cli.url' => '',
'dbtype' => 'mysql',
'version' => '',
'dbname' => 'domain_owncloud',
'dbhost' => 'localhost',
'dbtableprefix' => 'oc_',
'mysql.utf8mb4' => true,
'dbuser' => 'domain_mike',
'dbpassword' => 'mypass',

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.


If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder
Command won't run.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/...

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/...

LDAP configuration (delete this part if not used)

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration


Operating system:


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include: a) The javascript console log b) The network log c) ...

Try this:

`mysql -uroot

use owncloud;

ALTER TABLE oc_dav_shares ADD publicuri VARCHAR(255) NOT NULL AFTER principaluri;


Yea, I couldn't even get that command to work. Seems the user can't write to the owncloud DB it "looks" like to me. My public_html permissions should be diggscloud:nobody or diggscloud:diggscloud? It is a regular VPS, I have full control and have done everything the same since I started using the earlier versions. This time should be easier since I'm trying to do a fresh install with a new database. Using MySQL.
There are only a couple settings on that first page. It is the DB setup.

And hit enter, that error just keeps coming up.

How did you execute the command?

It should work because it's the root user. You can use any other user to log in to the database.

You can try the command with sudo in front of it.

I'm confused, since I've done this install from when every version changed and never had issues. Now I'm trying to do the easiest part which is setup a new install with a fresh DB and all and spits out errors right away. I'm not well versed in sending commands to MySQL databases and the only way I've done that previously was open up MyPHPAdmin and used the command line in there. I think I need some more "dumb me" help.

Connect to your server via SSH, and execute the command.
ssh root@ip_server
Enter password
Execute command.

I use CentOS, and I can login natively as the root user. Trying to connect to the database right now in the terminal. What does anything have to do with the field oc_calandersupbscriptions where it seems to be bombing out? I do check the DB and there 0 tables, but when I enter all the info in the initial setup screen it does create all the tables, just happens not to like something in the setup script possible with that oc_calandersubscriptions field, according to the error, right? This is what I get from the command line:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES) [~]# mysql -u root -p
Enter password:
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES) [~]#

Well, after a little terminal rememberance:

MariaDB [(none)]> connect diggscloud_own
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Connection id: 1590
Current database: diggscloud_own

MariaDB [diggscloud_own]> ALTER TABLE oc_dav_shares ADD publicuri VARCHAR(255) NOT NULL AFTER principaluri;
Query OK, 0 rows affected (0.00 sec)
Records: 0 Duplicates: 0 Warnings: 0

MariaDB [diggscloud_own]> quit
root@host [~]#

The same error still pops up.

For mysql, use the mysql's root account during the ownCloud installation for the DB user and password. ownCloud will set up a custom account with all the required permissions. You might have to set a non-existent DB name so ownCloud can create it for you.

This is a VPS using CPANEL. The root account and owner is "diggscloud". When the database is created by default when I create the DB and user it puts "diggscloud" in front like this-> diggscloud_mike". I've also tried root and multiple variations. And when I create the DB I give the MYSQL DB user ALL privs to the DB.

I don't think its recommended to create just another thread of the very same question: . Its way better to show some minimal effort like i did by using a search like to find threads like or leading to some information that this should work again with oC 10.0.4