OC Updater: cURL error 60: SSL certificate problem: unable to get local issuer certificate

update_issue
updater
9.1.x
help

#1

Hello,

I got a notification of a new OC version 9.1.1 and did the following

Steps to reproduce
1. Go to Admin > Updater
2. Open update

Expected behaviour
OC downloading latest update

Actual behaviour
Got an error message:

[GuzzleHttp\Exception\RequestException] 
cURL error 60: SSL certificate problem: unable to get local issuer certificate

[GuzzleHttp\Ring\Exception\RingException]
cURL error 60: SSL certificate problem: unable to get local issuer certificate e

Server configuration
Operating system: Ubuntu 14.04.2
Web server: Apache 2
Database: MySQL
PHP version: 5.6.23
ownCloud version (see ownCloud admin page): 9.1
Updated from an older ownCloud or fresh install: Update
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):
Using Let's Encrypt SSL certificates for www.domain.com
OC located in www.domain.com/owncloud

ownCloud log (data/owncloud.log)

As far as I can see, the owncloud.log doesn't contain anything relevant. I specifically used tail -f and rerun the procedure above.

{"reqId":"SXHYdcXImheiIw+2KDna","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:44:08","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"SXHYdcXImheiIw+2KDna","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:44:08","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"SXHYdcXImheiIw+2KDna","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:44:08","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"SXHYdcXImheiIw+2KDna","remoteAddr":"192.168.1.1","app":"PHP","message":"file_exists(): open_basedir restriction in effect. File(\/var\/www\/clients\/client1\/web3\/web\/o\/themes\/mytheme\/apps\/tasks\/img\/tasks.svg) is not within the allowed path(s): (\/var\/www\/clients\/client1\/web3\/web:\/var\/www\/clients\/client1\/web3\/private:\/var\/www\/clients\/client1\/web3\/tmp:\/var\/www\/domain.com\/web:\/srv\/www\/domain.com\/web:\/usr\/share\/php5:\/usr\/share\/php:\/tmp:\/usr\/share\/phpmyadmin:\/etc\/phpmyadmin:\/var\/lib\/phpmyadmin:\/usr\/share\/php:\/home\/user\/oc\/data:\/dev) at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/URLGenerator.php#158","level":3,"time":"2016-11-05 09:44:08","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"SXHYdcXImheiIw+2KDna","remoteAddr":"192.168.1.1","app":"PHP","message":"file_exists(): open_basedir restriction in effect. File(\/var\/www\/clients\/client1\/web3\/web\/o\/themes\/mytheme\/apps\/tasks\/img\/tasks.svg) is not within the allowed path(s): (\/var\/www\/clients\/client1\/web3\/web:\/var\/www\/clients\/client1\/web3\/private:\/var\/www\/clients\/client1\/web3\/tmp:\/var\/www\/domain.com\/web:\/srv\/www\/domain.com\/web:\/usr\/share\/php5:\/usr\/share\/php:\/tmp:\/usr\/share\/phpmyadmin:\/etc\/phpmyadmin:\/var\/lib\/phpmyadmin:\/usr\/share\/php:\/home\/user\/oc\/data:\/dev) at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/URLGenerator.php#160","level":3,"time":"2016-11-05 09:44:08","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"SXHYdcXImheiIw+2KDna","remoteAddr":"192.168.1.1","app":"PHP","message":"file_exists(): open_basedir restriction in effect. File(\/var\/www\/clients\/client1\/web3\/web\/o\/themes\/mytheme\/apps\/tasks\/img\/tasks.png) is not within the allowed path(s): (\/var\/www\/clients\/client1\/web3\/web:\/var\/www\/clients\/client1\/web3\/private:\/var\/www\/clients\/client1\/web3\/tmp:\/var\/www\/domain.com\/web:\/srv\/www\/domain.com\/web:\/usr\/share\/php5:\/usr\/share\/php:\/tmp:\/usr\/share\/phpmyadmin:\/etc\/phpmyadmin:\/var\/lib\/phpmyadmin:\/usr\/share\/php:\/home\/user\/oc\/data:\/dev) at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/URLGenerator.php#161","level":3,"time":"2016-11-05 09:44:08","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"lgMFf8MF+lhcOBIvhyMB","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:44:13","method":"GET","url":"\/o\/apps\/updatenotification\/credentials","user":"adminuser"}
{"reqId":"lgMFf8MF+lhcOBIvhyMB","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:44:13","method":"GET","url":"\/o\/apps\/updatenotification\/credentials","user":"adminuser"}
{"reqId":"lgMFf8MF+lhcOBIvhyMB","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:44:13","method":"GET","url":"\/o\/apps\/updatenotification\/credentials","user":"adminuser"}
{"reqId":"lgMFf8MF+lhcOBIvhyMB","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:44:13","method":"GET","url":"\/o\/apps\/updatenotification\/credentials","user":"adminuser"}
{"reqId":"WRppK2cKmDOsDNXaidT4","remoteAddr":"192.168.1.1","app":"PHP","message":"file_exists(): open_basedir restriction in effect. File(\/var\/www\/clients\/client1\/web3\/web\/o\/themes\/mytheme\/apps\/tasks\/img\/tasks.svg) is not within the allowed path(s): (\/var\/www\/clients\/client1\/web3\/web:\/var\/www\/clients\/client1\/web3\/private:\/var\/www\/clients\/client1\/web3\/tmp:\/var\/www\/domain.com\/web:\/srv\/www\/domain.com\/web:\/usr\/share\/php5:\/usr\/share\/php:\/tmp:\/usr\/share\/phpmyadmin:\/etc\/phpmyadmin:\/var\/lib\/phpmyadmin:\/usr\/share\/php:\/home\/user\/oc\/data:\/dev) at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/URLGenerator.php#158","level":3,"time":"2016-11-05 09:57:49","method":"GET","url":"\/o\/settings\/admin","user":"adminuser"}
{"reqId":"WRppK2cKmDOsDNXaidT4","remoteAddr":"192.168.1.1","app":"PHP","message":"file_exists(): open_basedir restriction in effect. File(\/var\/www\/clients\/client1\/web3\/web\/o\/themes\/mytheme\/apps\/tasks\/img\/tasks.svg) is not within the allowed path(s): (\/var\/www\/clients\/client1\/web3\/web:\/var\/www\/clients\/client1\/web3\/private:\/var\/www\/clients\/client1\/web3\/tmp:\/var\/www\/domain.com\/web:\/srv\/www\/domain.com\/web:\/usr\/share\/php5:\/usr\/share\/php:\/tmp:\/usr\/share\/phpmyadmin:\/etc\/phpmyadmin:\/var\/lib\/phpmyadmin:\/usr\/share\/php:\/home\/user\/oc\/data:\/dev) at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/URLGenerator.php#160","level":3,"time":"2016-11-05 09:57:49","method":"GET","url":"\/o\/settings\/admin","user":"adminuser"}
{"reqId":"WRppK2cKmDOsDNXaidT4","remoteAddr":"192.168.1.1","app":"PHP","message":"file_exists(): open_basedir restriction in effect. File(\/var\/www\/clients\/client1\/web3\/web\/o\/themes\/mytheme\/apps\/tasks\/img\/tasks.png) is not within the allowed path(s): (\/var\/www\/clients\/client1\/web3\/web:\/var\/www\/clients\/client1\/web3\/private:\/var\/www\/clients\/client1\/web3\/tmp:\/var\/www\/domain.com\/web:\/srv\/www\/domain.com\/web:\/usr\/share\/php5:\/usr\/share\/php:\/tmp:\/usr\/share\/phpmyadmin:\/etc\/phpmyadmin:\/var\/lib\/phpmyadmin:\/usr\/share\/php:\/home\/user\/oc\/data:\/dev) at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/URLGenerator.php#161","level":3,"time":"2016-11-05 09:57:49","method":"GET","url":"\/o\/settings\/admin","user":"adminuser"}
{"reqId":"9EAR7g2CP9d3EVK24Gzh","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:57:50","method":"GET","url":"\/o\/avatar\/adminuser\/32","user":"adminuser"}
{"reqId":"9EAR7g2CP9d3EVK24Gzh","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:57:50","method":"GET","url":"\/o\/avatar\/adminuser\/32","user":"adminuser"}
{"reqId":"9EAR7g2CP9d3EVK24Gzh","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:57:50","method":"GET","url":"\/o\/avatar\/adminuser\/32","user":"adminuser"}
{"reqId":"9EAR7g2CP9d3EVK24Gzh","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:57:50","method":"GET","url":"\/o\/avatar\/adminuser\/32","user":"adminuser"}
{"reqId":"I9KBpMA\/LETTDycIfGiW","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:57:52","method":"GET","url":"\/o\/apps\/theme_switcher\/settings","user":"adminuser"}
{"reqId":"I9KBpMA\/LETTDycIfGiW","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:57:52","method":"GET","url":"\/o\/apps\/theme_switcher\/settings","user":"adminuser"}
{"reqId":"I9KBpMA\/LETTDycIfGiW","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:57:52","method":"GET","url":"\/o\/apps\/theme_switcher\/settings","user":"adminuser"}
{"reqId":"I9KBpMA\/LETTDycIfGiW","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:57:52","method":"GET","url":"\/o\/apps\/theme_switcher\/settings","user":"adminuser"}
{"reqId":"tPaGGEfK+rQSddU69vQE","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:57:54","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"tPaGGEfK+rQSddU69vQE","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:57:54","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"tPaGGEfK+rQSddU69vQE","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:57:54","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"tPaGGEfK+rQSddU69vQE","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:57:54","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"tPaGGEfK+rQSddU69vQE","remoteAddr":"192.168.1.1","app":"PHP","message":"file_exists(): open_basedir restriction in effect. File(\/var\/www\/clients\/client1\/web3\/web\/o\/themes\/mytheme\/apps\/tasks\/img\/tasks.svg) is not within the allowed path(s): (\/var\/www\/clients\/client1\/web3\/web:\/var\/www\/clients\/client1\/web3\/private:\/var\/www\/clients\/client1\/web3\/tmp:\/var\/www\/domain.com\/web:\/srv\/www\/domain.com\/web:\/usr\/share\/php5:\/usr\/share\/php:\/tmp:\/usr\/share\/phpmyadmin:\/etc\/phpmyadmin:\/var\/lib\/phpmyadmin:\/usr\/share\/php:\/home\/user\/oc\/data:\/dev) at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/URLGenerator.php#158","level":3,"time":"2016-11-05 09:57:54","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"tPaGGEfK+rQSddU69vQE","remoteAddr":"192.168.1.1","app":"PHP","message":"file_exists(): open_basedir restriction in effect. File(\/var\/www\/clients\/client1\/web3\/web\/o\/themes\/mytheme\/apps\/tasks\/img\/tasks.svg) is not within the allowed path(s): (\/var\/www\/clients\/client1\/web3\/web:\/var\/www\/clients\/client1\/web3\/private:\/var\/www\/clients\/client1\/web3\/tmp:\/var\/www\/domain.com\/web:\/srv\/www\/domain.com\/web:\/usr\/share\/php5:\/usr\/share\/php:\/tmp:\/usr\/share\/phpmyadmin:\/etc\/phpmyadmin:\/var\/lib\/phpmyadmin:\/usr\/share\/php:\/home\/user\/oc\/data:\/dev) at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/URLGenerator.php#160","level":3,"time":"2016-11-05 09:57:54","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"tPaGGEfK+rQSddU69vQE","remoteAddr":"192.168.1.1","app":"PHP","message":"file_exists(): open_basedir restriction in effect. File(\/var\/www\/clients\/client1\/web3\/web\/o\/themes\/mytheme\/apps\/tasks\/img\/tasks.png) is not within the allowed path(s): (\/var\/www\/clients\/client1\/web3\/web:\/var\/www\/clients\/client1\/web3\/private:\/var\/www\/clients\/client1\/web3\/tmp:\/var\/www\/domain.com\/web:\/srv\/www\/domain.com\/web:\/usr\/share\/php5:\/usr\/share\/php:\/tmp:\/usr\/share\/phpmyadmin:\/etc\/phpmyadmin:\/var\/lib\/phpmyadmin:\/usr\/share\/php:\/home\/user\/oc\/data:\/dev) at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/URLGenerator.php#161","level":3,"time":"2016-11-05 09:57:54","method":"GET","url":"\/o\/apps\/news\/","user":"adminuser"}
{"reqId":"BnuAluk4Xchm+Lb+LPPA","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:57:54","method":"GET","url":"\/o\/settings\/ajax\/checksetup","user":"adminuser"}
{"reqId":"BnuAluk4Xchm+Lb+LPPA","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:57:54","method":"GET","url":"\/o\/settings\/ajax\/checksetup","user":"adminuser"}
{"reqId":"BnuAluk4Xchm+Lb+LPPA","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:57:54","method":"GET","url":"\/o\/settings\/ajax\/checksetup","user":"adminuser"}
{"reqId":"BnuAluk4Xchm+Lb+LPPA","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:57:54","method":"GET","url":"\/o\/settings\/ajax\/checksetup","user":"adminuser"}
{"reqId":"CfqJywBCcHZ361qGNDsH","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:57:59","method":"GET","url":"\/o\/apps\/updatenotification\/credentials","user":"adminuser"}
{"reqId":"CfqJywBCcHZ361qGNDsH","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:57:59","method":"GET","url":"\/o\/apps\/updatenotification\/credentials","user":"adminuser"}
{"reqId":"CfqJywBCcHZ361qGNDsH","remoteAddr":"192.168.1.1","app":"PHP","message":"Undefined index: two-factor-providers at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#111","level":3,"time":"2016-11-05 09:57:59","method":"GET","url":"\/o\/apps\/updatenotification\/credentials","user":"adminuser"}
{"reqId":"CfqJywBCcHZ361qGNDsH","remoteAddr":"192.168.1.1","app":"PHP","message":"Invalid argument supplied for foreach() at \/var\/www\/clients\/client1\/web3\/web\/o\/lib\/private\/Authentication\/TwoFactorAuth\/Manager.php#112","level":3,"time":"2016-11-05 09:57:59","method":"GET","url":"\/o\/apps\/updatenotification\/credentials","user":"adminuser"}

Integrity status for oC9+

No errors have been found.

Update server 9.1.1 -> 9.1.2
Update crashes (since years) :(
#2

Hi,

just don't waste your time with the updater app and do the manual update without the updater app like explained here:

https://doc.owncloud.org/server/latest/admin_manual/maintenance/manual_upgrade.html


#3

But why?! Manual upgrade is such a pain in the neck! Moving all the apps, themes, settings... setting permissions again, not to mention all the clients that stop working in the meantime!

Won't it be possible to just fix the updater?


#4

Because the Updater App is not reliable and broken since ages. You see that with the issue you're currently facing. It even needs manual patching for some other issues (https://central.owncloud.org/t/patches-for-known-update-issues-from-version-9-0-4-9-0-5-9-1-0-9-1-1/3549).

In the time you have looked for a solution and posted here the manual update should be already finished.


#5

old topic…but same problem exists 2 years later. BUT…the “Manual Update” instructions indicate that the Update App is an option! Either the document is lame, or the person(s) that should be maintaining the “Updater App” is incompetent, lazy, lame, or some combination of all three.

Seriously…if it doesn’t work and is “well-known” as not working, then are you (Owncloud) advocating to use it?? Or why don’t you pull it from the product or get it fixed??


#6

Hey,

i did the following search:

https://www.google.com/search?q=“SSL+certificate+problem%3A+unable+to+get+local+issuer+certificate”

and found various links like the ones below. Maybe this is not an ownCloud issue at all and needs to be fixed in your environment? This could explain why you’re seeing the same issue two years ago.