Owncloud 10.0.10 errors on integrity check


#1

I upgrade owncloud 9.1.8 to version 10.0.10 on a Debian 9 server.
When I log in to my account I got the following error messages:

the contents of .htaccess is:

Version: 8.2.7

<IfModule mod_headers.c>

<IfModule mod_fcgid.c>

<IfModule mod_setenvif.c>

SetEnvIfNoCase ^Authorization$ “(.+)” XAUTHORIZATION=$1

RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION

</IfModule>

</IfModule>

<IfModule mod_env.c>

Add security and privacy related headers

Header set X-Content-Type-Options “nosniff”

Header set X-XSS-Protection “1; mode=block”

Header set X-Robots-Tag “none”

Header set X-Frame-Options “SAMEORIGIN”

Header set X-Download-Option “noopen”

Header set X-Permitted.Cross-Domain.Policies “none”

SetEnv modHeadersAvailable true

</IfModule>

Add cache control for CSS and JS files

<FilesMatch “.(css|js)$”>

Header set Cache-Control “max-age=7200, public”

</FilesMatch>

</IfModule>

<IfModule mod_php5.c>

php_value upload_max_filesize 513M

php_value post_max_size 513M

php_value memory_limit 512M

php_value mbstring.func_overload 0

php_value always_populate_raw_post_data -1

php_value default_charset ‘UTF-8’

php_value output_buffering 0

<IfModule mod_env.c>

SetEnv htaccessWorking true

</IfModule>

</IfModule>

<IfModule mod_rewrite.c>

RewriteEngine on

RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

RewriteRule ^.well-known/host-meta /public.php?service=host-meta [QSA,L]

RewriteRule ^.well-known/host-meta.json /public.php?service=host-meta-json [QSA,L]

RewriteRule ^.well-known/carddav /remote.php/carddav/ [R=301,L]

RewriteRule ^.well-known/caldav /remote.php/caldav/ [R=301,L]

RewriteRule ^apps/calendar/caldav.php remote.php/caldav/ [QSA,L]

RewriteRule ^apps/contacts/carddav.php remote.php/carddav/ [QSA,L]

RewriteRule ^remote/(.*) remote.php [QSA,L]

RewriteRule ^(build|tests|config|lib|3rdparty|templates)/.* - [R=404,L]

RewriteRule ^(.|autotest|occ|issue|indie|db_|console).* - [R=404,L]

</IfModule>

<IfModule mod_mime.c>

AddType image/svg+xml svg svgz

AddEncoding gzip svgz

</IfModule>

<IfModule mod_dir.c>

DirectoryIndex index.php index.html

</IfModule>

AddDefaultCharset utf-8

Options -Indexes

<IfModule pagespeed_module>

ModPagespeed Off

</IfModule>

ErrorDocument 403 /owncloud/core/templates/403.php

ErrorDocument 404 /owncloud/core/templates/404.php

someone can help me?


#2

Hey,

maybe you can help yourself by clicking on the “documentation” links behind each of the message. It looks to me like each message is thoroughly described there.

Using the search function on the top right of the forums could help as well. I have seen many existing threads about the posted messages which might give additional information.

After reviewing the documentation / threads i think most users are happy to answer you any specific questions you have to the documentation.


#3

I already tried to find something in documenatation, I repaired another error, but not this… I think should be something about wrong version of .htaccess, …
I’m think to uninstall owncloud e try with a fresh installation, but if someone can hel me tu understand something I will be very happy


#4

Hey,

if you’re only getting the integrity check message then i think it could be possible that you’re not uploading the new version of this file at all and so getting this error. See e.g. one of the following threads i had found using the search function:


#5

Thanks for your help!
Now I have to configure just memcache with redis, but I think i can solve by myselfe


#6

Hey,

nice. If you have further questions around memcache and redis which you can’t solve i would suggest to open a new thread asking specific questions around this topic.