Owncloud 10.6 + Owncloud Web switch doesn't work


I have just upgraded to 10.6 which works. Then I wanted to try Owncloud web.

I followed the guidelines on https://owncloud.github.io/clients/web/deployments/oc10-app/

I installed oauth2 and web apps as requested from the marketplace.
I added a client into users authorisation to get a clientid
I configured config.php to add the web.baseUrl as requested
I also configured web/config.json as requested (clientid + url) and copied it to /config (shell I delete the old under /web ? )

The new icon “new design” then appeared.
If I switch to the new design interface, I just get back to /apps/files. So the old design.

The integrity check of files shows me that for “web” the file .htaccess is missing

Checking the browser console I get:
“Content Security Policy: Die Einstellungen der Seite haben das Laden einer Ressource auf inline blockiert (“script-src”).” fingerprint-protection.js:343:25
Translated it says sth. like the preferences of the website have blocked an inline ressource.
However I get that on every page on Owncloud.

The log records nothing.

Any idea?

Thank you

I could solve the problem by updating Owncloud Web from 1.0.0 to 1.0.2


No, web/config.json is at the correct location, not at /config.

I actually get a blank page if I don’t put the config.json in /config.
And I do understand their guidelines just like that:

Please copy config.json.dist from the web app directory into config/config.json and adjust it according to the following example:

@mugioc You’re right, I have overseen this, I made my edits in web/config.json and it was working out of the box. Very strange. Now I have moved the file to /config and it’s still working…

BTW, there is already earlier thread on this topic.

1 Like

Yes. By the help of that thread I formulated my problem.
However they ended up in a blank page end that was not my first problem.

Well, but now it works. Owncloud Web looks beautiful.

@mugioc Nice, but what exactly was the problem with your installation?

Everytime I hit the button “New Design” it just loaded the old one.
So it didn’t change the path to /apps/web but kept /apps/files.

Yes, but what have you changed that it works now?

1 Like

I first had installed Owncloud Web 1.0.0
Then I looked at the github-Repository and found a newer version 1.0.2 . Installed this one and since then it has worked.


Ah thanks, I see. Here it’s working with 1.0.0.

1 Like

Even stranger:

  • Setting up 1.0.0 from market and configured in apps-external/web/config.json -> seems to work.

  • Moving config.json to config/config.json (according this post) -> still working.

  • Upgrading to 1.0.2 from market. Doesn’t work anymore, “Config file missing”.

  • Moving config/config.json back to apps-external/web/config.json -> working again.



Same problem here with Owncloud 10.8.0 + app Web 3.4.1

Everytime I hit the button “New Design” it just loaded the blank page /index.php/apps/web/index.html#/
If I hit F5 several times, it loaded a page with “Missing or invalid config. Please check if the file config.json exists and is correct.”

I have read 20 times this link Deploy as an app in ownCloud 10 | ownCloud , but I don’t understand my mistake.
config.json is in both /config/ and /apps/web/

Any advice?


Did you make sure they are readable by your webserver user (most probably www-data)? What does ls -la config.json tell?

1 Like


It tells that my webserver user can read/write config.json.


My owncloud is blocked on the redirect page :frowning:

Owncloud Server 10.8.0
Web 4.0.0

Any with the same issue?

Best Regards,
Bruno F. Cantante

Hey @Bruno_Cantante,

i think you should open a new topic as i think it is not relevant to the topic. From what i know a template is showing up for newly created topics and i have seen in the past that the information asked within that template is helpful for getting support.

@Bruno_Cantante Agreed, especially because the latest issue relates to a newer version of ownCloud and the failure differs from the OP’s issue.

1 Like


it seems that there is also an existing topic about this redirect message available here: