Problems Syncing Very Large Files

9.1.x
webserver_issue

#1

Steps to reproduce

  1. Install ownCloud Link
  2. Setup HTTPS for domain name Link
  3. Create mySQL database
  4. Setup Redis caching Link
  5. Turn on encryption inside owncloud settings

Expected behavior

Files up to the maximum file size limit stated (10 GB) should upload without a problem.

Actual behavior

Extremely large files fail to upload whether it be from a desktop client or the web app. My test file is typically a 4 GB operating system iso.

I have gone through as many troubleshooting methods as possible. I've made a post about this before here Link. I wiped my server entirely, reinstalled ownCloud, and made no changes to it and it still failed to upload large files over the internet. If I am on my local network it works fine. At this point I'm out of ideas with what to do.

Server configuration

Operating system: Ubuntu Server 16.04.02 LTS

Web server: Apache2

Database: MySQL

PHP version: 7.0.15

ownCloud version: 9.1.5

Updated from an older ownCloud or fresh install: Fresh install

Where did you install ownCloud from: Command line (see link above)

Signing status (ownCloud 9.0 and above): Not sure what this is asking

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
Results below
No errors have been found.

The content of config/config.php:

https://gist.github.com/JosephBateh/77658a8ede0fbcbd9bc0889a69ec9514

List of activated apps:

Enabled:
  - activity: 2.3.2
  - comments: 0.3.0
  - configreport: 0.1.1
  - dav: 0.2.7
  - encryption: 1.3.0
  - federatedfilesharing: 0.3.0
  - federation: 0.1.0
  - files: 1.5.1
  - files_pdfviewer: 0.8.1
  - files_sharing: 0.10.0
  - files_texteditor: 2.1
  - files_trashbin: 0.9.0
  - files_versions: 1.3.0
  - files_videoplayer: 0.9.8
  - firstrunwizard: 1.1
  - gallery: 15.0.0
  - notifications: 0.3.0
  - provisioning_api: 0.5.0
  - systemtags: 0.3.0
  - templateeditor: 0.1
  - updatenotification: 0.2.1
Disabled:
  - external
  - files_antivirus
  - files_external
  - user_external
  - user_ldap

Are you using external storage, if yes which one: none

Are you using encryption: yes

*Are you using an external user-backend, if yes which one: *Don't think so?

Client configuration

Browser: Chrome, Safari

Operating system: Windows 10, MacOS

Logs

Web server error log

https://gist.github.com/JosephBateh/08a5f5d53a0ccbd83c7a58185443b3c4

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

Browser log

Insert your browser log here, this could for example include:
When on admin page: GET https://neon.josephbateh.com/owncloud/data/htaccesstest.txt?t=1494643726715 403 (Forbidden)

Trouble Syncing Files
#2

If there is a difference between "over the internet" and "local network" then just one of the many timeouts in the webserver, PHP or similar are kicking in.

Unfortunately there is "single" solution for this possible so watching logfiles like the one of your webserver, the PHP error log or the data/owncloud.org might help you debugging this issue.


#3

I've been monitoring that, the problem is I don't know how to fix them. I have changed the timeout values with no success. If you could recommend settings to change for the problem, I would really appreciate it. Maybe I missed one of the possible options.


#4

All known limits which might be required to raise are documented at the following resources [1] or [2]. Maybe you have missed one listed there.

[1]
https://doc.owncloud.org/server/latest/admin_manual/configuration_files/big_file_upload_configuration.html

[2]


Am I setting up ownCloud correctly?
#5

I think the problem was the router I was using. It was an Apple Time capsule router. I've since switched to Google Wifi (connecting using an ethernet cable) and the problem has disappeared.