Trouble Syncing Files

9.1.x
help

#1

First I'd like to say that I have looked into potential fixes for this problem and tried several with no success. Articles/FAQs I find are not exactly my problem. Another thing to add was that I did not have this problem when I was syncing over my local network.

Steps to reproduce
1. Upload large files with ownCloud desktop client on Windows 10

Expected behaviour
File uploads without a problem

Actual behaviour
Unable to write / operation cancelled

Server configuration
Operating system: Ubuntu Server 16.04.1
Web server: Apache2
Database: MySQL
PHP version: 7.0.15
ownCloud version (see ownCloud admin page): 9.1.4
Updated from an older ownCloud or fresh install: Fresh install
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption): Data drive is an internal hard drive that is not the boot drive

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808 for more info

Exception: {"Message":"HTTP\/1.1 400 expected filesize 10000000 got 5095424","Exception":"Sabre\\DAV\\Exception\\BadRequest","Code":0,"Trace":"#0 \/var\/www\/owncloud\/apps\/dav\/lib\/Connector\/Sabre\/File.php(103): OCA\\DAV\\Connector\\Sabre\\File->createFileChunked(Resource id #60)\n#1 \/var\/www\/owncloud\/apps\/dav\/lib\/Connector\/Sabre\/Directory.php(136): OCA\\DAV\\Connector\\Sabre\\File->put(Resource id #60)\n#2 \/var\/www\/owncloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(1036): OCA\\DAV\\Connector\\Sabre\\Directory->createFile('2017-04-10-rasp...', Resource id #60)\n#3 \/var\/www\/owncloud\/3rdparty\/sabre\/dav\/lib\/DAV\/CorePlugin.php(523): Sabre\\DAV\\Server->createFile('Storage\/Documen...', Resource id #60, NULL)\n#4 [internal function]: Sabre\\DAV\\CorePlugin->httpPut(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#5 \/var\/www\/owncloud\/3rdparty\/sabre\/event\/lib\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#6 \/var\/www\/owncloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(459): Sabre\\Event\\EventEmitter->emit('method:PUT', Array)\n#7 \/var\/www\/owncloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(248): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#8 \/var\/www\/owncloud\/apps\/dav\/appinfo\/v1\/webdav.php(57): Sabre\\DAV\\Server->exec()\n#9 \/var\/www\/owncloud\/remote.php(164): require_once('\/var\/www\/ownclo...')\n#10 {main}","File":"\/var\/www\/owncloud\/apps\/dav\/lib\/Connector\/Sabre\/File.php","Line":404,"User":"joseph"}

Integrity status for oC9+

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.
No errors have been found.

Problems Syncing Very Large Files
#2

Mhhh, here is one FAQ available here exactly matching the error you're getting:


#3

I guess my word choice was poor. I've seen many FAQs/etc about a similar or exact error but none of them have yielded a result that has solved my problem, including the article you have linked.


#4

Unfortunately those are all known information about this issue. There might be even more in your environment / webserver / php setup so additional infos which could be added to the FAQ are always welcome if you find a solution for this.


#5

What is a large file for you? The client uses chunking, default size is about 5 MB, did you change that? Do all uploads for file above 5MB or 10 MB fail?
Do you use the mod_php in apache?


#6

As of right now a large file is something over 250MB because that is the largest file I have uploaded in the last few days without a problem. Most of the files I have been trying recently have been over 1GB. I do not think I'm using mod_php, mostly because I don't exactly know what that is. If it was automatically installed/used I wouldn't know. Another piece of information is that it doesn't matter where I upload. It's not just the client. The uploading through the web browser also fails for large files.


#7

Another nugget of information. If I try and delete the folder that I'm trying to upload to it says there is an error and can't delete it.

Exception: {"Message":"HTTP\/1.1 423 \"Storage\/Documents\/Operating Systems\" is locked","Exception":"OCA\\DAV\\Connector\\Sabre\\Exception\\FileLocked","Code":0,"Trace":"#0 \/var\/www\/owncloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Tree.php(179): OCA\\DAV\\Connector\\Sabre\\Directory->delete()\n#1 \/var\/www\/owncloud\/3rdparty\/sabre\/dav\/lib\/DAV\/CorePlugin.php(285): Sabre\\DAV\\Tree->delete('Storage\/Documen...')\n#2 [internal function]: Sabre\\DAV\\CorePlugin->httpDelete(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#3 \/var\/www\/owncloud\/3rdparty\/sabre\/event\/lib\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#4 \/var\/www\/owncloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(459): Sabre\\Event\\EventEmitter->emit('method:DELETE', Array)\n#5 \/var\/www\/owncloud\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(248): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#6 \/var\/www\/owncloud\/apps\/dav\/appinfo\/v1\/webdav.php(57): Sabre\\DAV\\Server->exec()\n#7 \/var\/www\/owncloud\/remote.php(164): require_once('\/var\/www\/ownclo...')\n#8 {main}","File":"\/var\/www\/owncloud\/apps\/dav\/lib\/Connector\/Sabre\/Directory.php","Line":283,"User":"joseph"}

This is also a warning that showed up after trying to delete the folder (which is empty)

Temporary directory /tmp/owncloudtemp is not present or writable

#8

For the file locked message a FAQ is available at https://central.owncloud.org/t/file-is-locked-how-to-unlock/985

The temporary dir is something which needs to be fixed directly on server side / in your PHP configuration (permissions, upload_tmp_dir php.ini entry etc.)


#9

Switching to redis solved the lock problem. Still working on the uploads failing.


#10

1) Could this have something to do with the fact that I moved my data directory to an internal HDD that is not the boot drive?
2) It looks like I'm getting:

[Sat Apr 22 16:28:31.802255 2017] [core:notice] [pid 1283] AH00052: child pid 1722 exit signal Segmentation fault (11)

In my error.log file located at /var/log/apache2

3) It seems to be a timeout problem based on what I've read and the fact that I didn't have this problem on my local network (much faster than my current internet connection). Where are the best places to change the timeout? I've tried several different places that were suggested but none of them fixed the problem.

4) this is how I installed owncloud: https://www.digitalocean.com/community/tutorials/how-to-install-and-configure-owncloud-on-ubuntu-16-04


#11

You just can't move the data directory after the installation as you need to do some additional modifications in your database as explained in the documentation [1].

Those shows some serious issues in your webserver. Unfortunately this is nothing where we in here can help with so you might need to report a bug to your used linux distro.

[1] https://doc.owncloud.org/server/10.0/admin_manual/maintenance/manually-moving-data-folders.html


Am I setting up ownCloud correctly?
#12

Okay, thank you for all your help. I plan on wiping the hard drive and starting over with a clean install.


#13

The problem was my router. I also answered the question more in depth here.